No more sound via USB Audio Interface (but its activated and works with JACK)

Hi there,
I got a really strange misbehaviour in my GNOME MJ with 5.13 Kernel.

If I set my Sound Output (and Input) in system configuration to my USB Audio Interface (Focusrite Scarlett 2i2) as always, it still plays sound to the internal soundcard from my laptop.
But if I start JACK with PulseAudio bridge, it plays the system sounds without flaws through my usb sound system.

IDK where to start looking about this issue.
It’s normally shown in “lsusb” and should work. Pulse Audio restart or reset does not work.

first it would be nice if you installed inxi and showed the output to

$ inxi -Axxx

Leaping ahead…most internal sound devices use kernel module snd_hda_intel
so if you created a blacklist config and full reboot to disable intel …that would be a start,
but do you need intel device?

$ cat /etc/modprobe.d/blacklist.conf
install snd_hda_intel /bin/true

Secondly…ALSA tends to “never” give index=0 to usb devices. But if you always use usb sound devices, we can fix that, with luck

How about showing us (so we can see the indices) …that is aplay lowercase L

$ aplay -l

1 Like
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo ThinkPad T480 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71 
  class-ID: 0403 
  Device-2: Focusrite-Novation Focusrite Scarlett 2i2 2nd Gen type: USB 
  driver: snd-usb-audio bus-ID: 1-2.4:27 chip-ID: 1235:8202 class-ID: 0102 
  Sound Server-1: ALSA v: k5.13.13-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: yes 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: yes

Yes. I “need” both alternating.

**** List of PLAYBACK Hardware Devices ****
card 0: USB [Scarlett 2i2 USB], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC257 Analog [ALC257 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This file is nonexistent.

I fixed it in tlp (TLPUI) somehow.
I un-and-re-checked usb-autosuspend and usb_blacklist and after a restart it works as it should.

1 Like

since you need intel …no need to create that blacklist file

but you are running both pulseaudio and pipewire. I know little about pipewire but you might like to read

essentially …Alsa is a backend and the other 2 are front ends.

i am also facing same error, how can i solve this?

If the solution already posted does not work for you it is unlikely to be the exact same error

I suggest you start a new topic and post system information and diagnostics in similar manner to OP

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.