No Linux distro detects Dell Inspiron 11 3148's wireless adapter

I am trying to install a Linux distro on this old laptop, which sports a 1.70GHz processor but also has a touchscreen.

So far, no distro has been able to connect with the wireless adapter (the device doesn’t appear when I try ip addr or similar).

Where can I find Linux compatible wireless adapter firmware for this model? The Dell site only reports a host of options for Windows executables.

What’s the output of lspci | egrep -i '(network|wireless)'?

Please wait, I’ll run that command asap.

Meanwhile, it seems that this is a fairly rampant issue with this laptop model on any distro:

  • https
  • https ://
  • https ://
  • https
    :// (also provides a solution for Ubuntu)
  • https

It’s also plagued generally by issues with its driver.

Some sites tell that I have to find the “broadcom” driver under Additional Drivers.

Let’s try all of the above. Obviously the terminal command is the first step.

I got Broadcom BCM43142 802.11b/g/n (rev 01).

There is a thread on Arch forum labeled solved - it is quite old but so is your system :grin:

Edit: Everything finally works now!! I installed :// and carefully followed the instructions over at ://
What I learned from this: rtfm for sure. Thank you all, for trying your best to help me out. Especially to twelveeighty for making this!
– ://

This link doesn’t work.

what about this driver?

Broadcom bluetooth firmware for BCM43142A0 based devices.


Firmware for Broadcom B43 wireless networking chips - latest release

Firmware for Broadcom B43 wireless networking chips - trusted release

I had come across these links.

Unfortunately, this wiki seems to be discouraging about driver support for B43142:

I also didn’t find bcm43142 on AUR through Octopi (I’m currently testing out KaOS).

I did install broadcom-wl from Octopi - didn’t find its *-dkms version if these aren’t the same thing.

broadcom-wl got installed automatically once the Manjaro Hello setup was done.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.