No keyboard input at LUKS passphrase prompt


I’m having an issue where my laptop is not responding to keyboard input (from neither my inbuilt nor external keyboard) when I get to the passphrase prompt screen to unlock my LUKS encrypted home drive (it still works in GRUB). This started happening yesterday after running an update and rebooting. I have tried solutions from various threads, specifically, putting keyboard, keymap and consolefont before autoload in my mkinitcpio hooks, and adding atkbd to modules, then rebuilding initramfs, aswell as downgrading systemd (all from a manjaro-chroot on a manjaro architect live usb). None of these solutions have worked.

Could it be the case that it has something to do with me having a brand new keyboard plugged in at the time of the update? It was the first time i’ve run a -Syu with an external keyboard plugged in on this laptop - or is that just a coincidence?

I’m running kernel 4.19 LTS on a Dell G5.

If worse comes to worse, what are the chances of simply being able to do a fresh install while keeping the contents of my encrypted home intact? fortunately they are on separate drives

Thanks in advance!

When you run mkinitcpio it will include connected devices in the initrd.

Anything placed before the autodetect in the HOOKS array of mkinitcpio will be included even if it is not connected at the time when you generate the initrd. I assume this is what you meant with the autoload reference and it the way to get a multi-purpose initrd.

Keyboards rarely fails - if they do it is either completely dead or in case of brand new keyboards it is often single keys which - for some unknown reason produces a weird scan code not recognized for the expected key - and though it is rare for keyboard failure - multi-functional Windows programmable keyboards are those most prone to this behavior.

If you shutdown your - Dell G5 (laptop I suppose) - unplug the external keyboard before powering up - will it fail to recognize the built-in keyboard?

Have you tried with another keyboard you may have around?

As you mention Linux 4.19 - is this because the system is old or just a coincidence?

As you specifically mention you are able to use the keyboard when using a live boot - is this the new keyboard or the built-in keyboard?

Thanks for your response,

Both keyboards work during boot, in the live usb environment, and while booted into my windows partition, the input only stops once I am put into the LUKS unlock screen, so it’s can’t be a hardware issue. They were also both working totally fine when I initially was using the keyboard, before I upgraded my system and powered off.

I mentioned my alterations to the mkinitcpio hooks because those were the suggestions that solved the same (or a similar) issue for other people from some threads I found (It’s not letting me post any links because my account is new, but one of the posts is titled “Keyboard does not work at LUKS password prompt” in archlinux forums), something about autoload not finding the correct drivers before I get thrown into the LUKS unlock screen. I also did try your suggestion of leaving it unplugged during boot already, to no avail.

I use the 419 kernel because the non LTS kernel I was using before was giving me grief - I don’t remember exactly what though, it was a while ago

When you installed Manjaro - did you use the default Calamares installer with default full encryption?

Or did you use a custom installation with an unencrypted boot partition? Not to be confused with the EFI system partition.

If you boot a Manjaro ISO - and unlock your root partition - and chroot to the existing Manjaro system - did you run the following commands after editing the mkinitcpio.conf? Even if you can confirm you did - please do it again - and note any important messages (grub not recognizing nvme is not important).

# mkinitcpio -P


# grub-mkconfig -o /boot/grub/grub.cfg

Is the system a desktop system - just searched for Dell G5 - it appears a desktop - am I correct?

Could it be related to the vendor blob which no one knows if it’s GPL or not?

I installed using manjaro architect and I only encrypted my home partition, which lives on a separate drive to my boot and root partitions. I didn’t use the installer because it was failing to partition and encrypt my drives, again I don’t remember exactly what the issue was then cause it was too long ago

I ran only mkinitcpio -p linux419, I’ll try your suggestion now

also here is the hooks line of my mkinitcpio.conf if that can tell you anything HOOKS=(base udev keyboard keymap consolefont autodetect modconf block encrypt filesystems resume fsck)

The G5 is a laptop. I’ve had little to no issues with it up until now.

Ok it did not work, but now I don’t get a grub menu anymore, it just goes straight to the LUKS unlock screen haha, I guess I can fix that if I manage to get back in