No internet with Wireguard-based VPN

I have tried to connect to a VPN by Blokada, see the connection script here. I downloaded the zip from the master branch and extracted and edited it to remove one of the packages so it would run setup. Typing in sudo wg-quick up blokada works without terminal errors, but the internet itself for the most part doesn’t work with the VPN active. I have no idea what logs to upload or how to attack this in general. So feedback would help.

For the he packages referenced, wireguard-arch does not seem to exist in the manjaro nor arch repositories.
From what I can tell the wireguard-arch package was needed to get wireguard support until it was mainlined into the kernel.

What is for the most part? can you ping a public dns server and/or do some dns lookups?
Do you use the plus option that actually has a VPN service?
Otherwise it seems you only get a free dns service from witch the data can be sold on to marketeers to cover the hosting costs and some sort of addblocking service.

The best support would probably be had from the creator of the script or

Why? Blokada blocks ads on Android using a local VPN as a workaround to block ads system-wide without root. This functionality is not needed on a desktop OS as you can just install an adblocker browser extension.

As for why, the VPN is alright for hiding your IP from various parties, although I know it’s not a privacy guarantee as a lot of VPNs claim in advertisements, and also I already have uBlock Origin installed. Their DNS server doesn’t support adblocking yet. I can try pinging the DNS server and yes I actually have the Plus service. And I agree that free VPNs are junk. Government honeypots. As for the wireguard-arch package that was mentioned, that was what I commented out in hope of it working. I just did not know where to start with troubleshooting. I will reach out to the support channel there if I cannot come up with a conclusion mostly on my own shortly. Support there would be better. UPDATE: I pinged Google, Cloudflare, Quad9, etc. (DNS server for the VPN being Quad9) and every single request times out. No wonder Firefox wouldn’t load anything.

What is your goal? Why are you wanting to use Blokada? Maybe another service would suit your needs better via official applications instead of a script created by an unknown party.

Honestly I purchased the VPN to support the developers and because it could be used in certain situations where Tor was just too slow (even though in many cases it’s great), plus on Android the only way at the time when I started using their app to get the ad blocker working with a VPN was to purchase their VPN, as the adblocker already used the VPN functionality, and only one VPN can run at a time of course. I have raised the issue on their forums as suggested. I will consider other services as well. I’ve heard Mullvad is good.

I can vouch for mullvad, works really well on manjaro plus there’s a gui in the aur that makes everything simple

I also use Mullvad and am the maintainer for all the Mullvad AUR packages except for the CLI version. It’s based on my PKGBUILDs, so it should work fine as well.


Well since my year of Blokada VPN is almost gone and there’s an option that’s mobile friendly to block ads and trackers in Mullvad, I subscribed to it. I will still watch the post in the Blokada community. And yes I can tell you it works well on every platform I’ve tried it on. I’ve heard tons of well-respected technically knowledgeable people recommend mullvad. Would’ve switched sooner if I knew about the ad and tracker blocking. Not every browser platform combo (ex. Chrome for Android) supports adblock. And I needed something that would both block junk and be a good VPN. Of course, for many things, TOR is better as it’s so decentralized nobody can easily track it. Including governments.

1 Like

Have you tried bromite on android? It’s degoogled chrome for android, all Google tracking removed

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.