No internet when connected though openVPN + pi hole

I just setup my home network like this:

  • Main router ( 7530 set to forward DNS for lan devices to
  • RockPro64 ( NAS + pi hole + openvpn + nginx hosting my personal website (say + firewalld

Nginx is configured to only allow requests from (lan devices) and (vpn devices). It drops other requests. This is working fine.

I use pihole to block ads and also to have some local dns records for So, from my LAN, is served locally, never reaching the internet.

I also setup a openvpn server so that I can access like if I was at home and this works fine.
My issue is that, when I am connected through openVPN, I have no internet connectivity. I can only browse

I followed the official pihole guide to configure it with openVPN, but when I run pihole -a -i all to have pihole listen to both eth0 and tun0, I lose internet connectivity to all my LAN devices, so currently pihole only listens to eth0. I guess this is the root cause of my issue.

I just double checked and firewalld is correctly configured to allow DNS. HTTP and HTTPS traffic for both LAN and openvpn zones. I also enabled masquerade for openvpn zone.

Does anyone know how to fix this? Or at least provide some hint on what I could try to isolate the issue?

I did not find any solution yet, so I switched to NOT routing client traffic through openVPN. Now it works.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.