No internet on a new install of Manjaro

I got my friend to install Manjaro and try it out.
He was using Windows 10, and he used some random software to reduce the size of Windows 10 partition, and it worked fine, he rebooted into the USB, he had internet during the install process.
After he rebooted into the installed system, he had no internet. It said “Limited connection” on the bottom right and it just did not work.
I’m a newbie to Linux so I don’t really know how to start, I tried setting a manual IPv4 address, nothing.
We booted back to USB live system and that didn’t have internet now.
It seems really strange why any network connection stopped working in the USB system.
If more info is needed just ask, thanks for the help.
Some info: Network device is from a A320 S2-H, Realtek RTL 8111/8168/8411
ip a doesn’t show any IPv4 Adresses, status says it is LOWER_UP and state UP

Hi @zerowhy,

I can’t tell you anything more than it seems to me the problem is either the router or the cable. (If there is a cable, if not, well then it still looks like the router. Or the connection.)

Try turning the router off and on again. And re-plugging the network cable.

Else :man_shrugging:

We already tried that, we are now re-installing the system to see if it helps.

OK, it actually sounded like than when you said the connection stopped working, when it previously did work, in the Live ISO environment.

1 Like

Yes, that is what happened.
And after we booted back to the live ISO environment it also didn’t have internet. really strange

Do you have another computer or device on which wifi or ethernet works as usual ?

1 Like

Every other device is working fine.

The live iso is not persistent anyway. If you do have internet and don’t have anymore some hours later, your root issue does not come from the iso.
Check your router settings maybe, your cable etc…
Try to ping your other devices, check you dhcp client service


I had issues with the r8168 and r8169 drivers conflicting and had to remove the r8168 to solve. You might look into which is working and which is not.

1 Like

How would I check which is working and proceed to remove it?

Did you disable ‘fast boot’ in Windows (you have a dual boot right?), it can mess up a little bit sometimes, network interfaces especially

Soo, about Windows.
That is another problem. I think the shrinking of the partition caused some problem and it doesn’t boot, just blue screens.
I can access Windows CMD, I will try to run a command to shut it down fully, maybe it can help. Does fast boot in UEFI Bios have to be disabled too?

It does. And make sure “Secure boot” is likewise disabled.

Doesn’t appear to be an option of Secure Boot in UEFI Bios

Yes, i was confused.
In uefi it’s called fast boot usually.
In windows, i think it’s fast startup.
Disable them both.
Disable secure boot in uefi
Drivers on AHCI (in uefi)
No legacy (in uefi)
No CSM (in uefi)

OK, disabled CSM and option to disable Secure Boot appeared.
Booted to USB live environment and still nothing changed.
EDIT: I’m think of deleting windows and Installing manjaro only. I will just backup some data and do that.

It was Windows 10 all along. Thanks @yannssolo for the suggestion!
I formatted the entire disk and it worked lol

Just for future people: If there are problems with network with dual boot solution with Windows, either disable fast boot on Windows or delete it from your system.

Nice !
Now, enjoy Manjaro :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.