No Internet Access when connected to repeater

Hi all,
i installed Manjaro Linux for the first time. It is another try to switch from Windows to Linux, but as usual, i am facing some problems.

I have Internet access via WiFi using my standard network connection. In my office, the connection quality is low, thats why i have installed a repeater. When I connect my Wifi to the repeater network …[NETWORK_NAME]_EXT, I have no internet access. Connection to the network works. I do not have this problem on other devices, also not on my old Lubuntu netbook… any ideas someone? Thank you

Is the repeater acting also as a DHCP server? If not, then maybe you need to manually assign the IP on your Manjaro install wifi connection.

I assume, that it is working as DHCP, because all other devices connected to the repeater get an random IP-Adress automatically…

tried it out to give adress manually now, no success

Now it is getting strange… Looks like I have internet access, but there are a couple of big websites, which will be displayed as not available, but others work… i am lost…
it is the same in firefox and in chromium … e.g. google, facebook, this forum working, others like spiegel, stern, gmx, not working

check your DNS settings. Try with another DNS, OpenDNs, Yandex, Google etc.

I have entered the following in the details of the network connection [NETWORK_NAME]+EXT,,, it should be the DNS Server Adress from goolge. I guess. When I change resolv.conf it is somehow restored to the old entry after reboot. Yes i am a linux novice, sorry for that stupidity

I found out, that I do not have the problem when I am not connected via the repeater. So I assume, it can not be a DNS Problem on my computer

I have still the problem: Connected to [MY-WIFI-NAME] everything works. When connecting with the repeater [MY-WIFI-NAME]+EXT only some websites are available. Set my IP-Adress to static, added addional DNS-Servers. Anybody else an idea?


  • Reset the repeater, follow the instructions and set it up again it is obviously malfunctioning.
  • Return the repeater to the place you got it from and get different item.
  • Contact manufacturer for support
  • Contact your ISP, maybe they have a list of devices that are certified with the current main box you use or they can assist with the setup or are able to provide a extender for your situation, depends a bit on what kind of ISP you have.

Thanks Hanzel,
the problem does not occur in my lubuntu netbook, not on my android systems and not on the windows desktop, neither on the iphone of my wife. so i think it is not a problem of the repeater, but something which is wrongly configured in my manjaro linux system.

When you use your WiFi repeater and have only partial host available, try to start to diagnose the issue you met:

a) does the

networkctl status


ip address show

show valid DHCP/manual IP (no other machine in your local network has the same IP; got neither a broadcast nor a network address)?

b) Does

cat /etc/resolv.conf

show valid DNS?

c) are you using IPv4 or IPv6?

d) does specially designed network probing tools like ping and tracepath are useless for you?
Are there all good if trying to reach you gateway, dns, your nearest provider host (including TTL value, package loss on 200+ packets transmitted are as expected)?

e) journalctl -p3 -b,
journalctl -p3 -k
and journalctl -p4..4 -k
does not report possibly network-related issues?

f) had already posted your system information? (How to provide good information)

g) has the latest available firmware set?

pacman -Qi linux-firmware | grep -i "Version"

like this?

Version         : 20211027.1d00989-1

h) is it able to reach WiFi access point w/o repeater? Yes, signal level is low, may be you can temporarily move WiFi repeater or your machine to get a bit stronger signal to try to connect to it directly and to report does the direct connection to WiFi AP resolves the several-hosts-unavailability issue or not.

Now it works. I have deleted the DNS cache and did a restart.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.