No incoming notifications or outgoing audio feedback

Audio generally works on my system – like when I play audio or video or while using Skype and Signal – but notification sounds and ring feedback don’t appear. So I get no audible notification when a call arrives in those programs, and when I make outbound calls using them, I get no ring feedback. In Skype, the “test audio” function produces silence.

Any idea what I can do about this? To me it suggests that audio notification and feedback occupy a completely separate path from operational audio.

Welcome to the forum! :vulcan_salute:

The system does distinguish between system sounds and multimedia streams, but in addition to that, notifications also have highly differentiated settings for individual applications and events.

Your profile information states that you’re using Plasma. Have you checked your notification settings?

VOIP audio notifications use a separate audio stream in PipeWire/PulseAudio to audio from VOIP callers, so notifications could be playing audio to a different audio device

I suggest check audio streams in PipeWire or PulseAudio

pactl list sink-inputs
1 Like

Welcome to the Manjaro Forums!

I don’t use Signal but I do use Skype. You’ll need to adjust the individual volume slider for the ringer, in the Sound Settings, whilst it’s actually ringing (e.g. make a test call).

1 Like

Test Call service is no longer available in Skype

Audio streams are shown in GUI controls with a Chromium logo rather than a Skype logo

pactl list sink-inputs includes information about stream volume

$ pactl list sink-inputs
Sink Input #121
	Driver: protocol-native.c
	Owner Module: 5
	Client: 85
	Sink: 0
	Sample Specification: float32le 2ch 48000Hz
	Channel Map: front-left,front-right
	Format: pcm, format.sample_format = "\"float32le\""  format.rate = "48000"  format.channels = "2"  format.channel_map = "\"front-left,front-right\""
	Corked: no
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	Buffer Latency: 59812 usec
	Sink Latency: 7910 usec
	Resample method: copy
		application.icon_name = "chromium-browser" = "Playback" = "Chromium"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "35" = "983118"
		application.process.user = "nik" = "gnomic"
		application.process.binary = "skypeforlinux"
		application.language = "en_GB.utf8"
		window.x11.display = ":0.0"
		application.process.machine_id = "e1a1dbd021524f58a519eccfea07f8ea"
		application.process.session_id = "1" = "sink-input-by-application-name:Chromium"
1 Like

System settings → Sound → Playback Streams → Notifications Sounds → 100%.

Is there some other setting I should check?

Skype: all notifications turned on. Settings → Audio & Video → Test audio produces silence. Still not getting notifications.

“pactl list sink-inputs” produces nothing, with or without Skype running.

So I’m still stumped.