No icons in filelist Krusader 2.8.0-1

Hi fellows, after updating Krusader 2.7.2 to 2.8.0-1 I no longer see icons for folders or files in the main filelist window. Already tried several standard KDE themes to no avail. All was good with the old version of Krusader. In attash a screenshot of the problem. Same problem also occurs in my Debian unstable/SID installation, thus I think it must be some problem in the source file ? Also tried the Krusader-git version in aur, same thing happening there…

My systeminfo

  Host: imac Kernel: 5.10.155-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.24.7 Distro: Manjaro Linux
  Type: Desktop System: Apple product: iMac16,2 v: 1.0
    serial: <superuser required>
  Mobo: Apple model: Mac-FFE5EF870D7BA81A v: iMac16,2
    serial: <superuser required> UEFI: Apple v: 428. date: 10/27/2021
  Info: quad core model: Intel Core i5-5675R bits: 64 type: MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 2982 min/max: 800/3600 cores: 1: 2936 2: 2687 3: 3284
    4: 3022
  Device-1: Intel Iris Pro Graphics 6200 driver: i915 v: kernel
  Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    dri: iris gpu: i915 resolution: 4096x2304~60Hz
  API: OpenGL v: 4.6 Mesa 22.1.7 renderer: Mesa Intel Iris Pro Graphics
    6200 (BDW GT3)
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel 9 Series Family HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k5.10.155-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC driver: brcmfmac
  IF: wlp3s0 state: up mac: 28:f0:76:77:58:72
  Device-2: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe driver: tg3
  IF: eno1 state: down mac: a8:60:b6:1e:2f:b3
  Device-1: Apple Bluetooth USB Host Controller type: USB
    driver: btusb,hid-generic,usbhid
  Report: bt-adapter ID: hci0 state: up address: N/A
  Local Storage: total: 1.36 TiB used: 493.72 GiB (35.3%)
  ID-1: /dev/sda vendor: Apple model: HDD HTS541010A9E662 size: 931.51 GiB
  ID-2: /dev/sdb type: USB vendor: Samsung model: Portable SSD T3
    size: 465.76 GiB
  ID-1: / size: 182.36 GiB used: 94.63 GiB (51.9%) fs: ext4 dev: /dev/sdb3
  ID-2: /boot/efi size: 196.9 MiB used: 1.1 MiB (0.6%) fs: vfat
    dev: /dev/sdb1
  ID-1: swap-1 type: file size: 4 GiB used: 256 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 211 Uptime: 21m Memory: 7.64 GiB used: 3.8 GiB (49.8%)
  Shell: Bash inxi: 3.3.23

Many thanks in advance !
Cheers, Eddy

Seems related to hdpi scaling, a bug report on was already filed.
I do see the icons for folders and files when I start krusader with:

QT_SCREEN_SCALE_FACTORS="eDP-1=1;HDMI-1=1;DP-1=1;DP-2=1;DP-3=1;DP-4=1" krusader


I’m still running 2.7.2 from the stable branch. Hoping they have it fixed before it gets here.
I use Krusader about 80% of the time, terminal about 15 % or so of the time and Dolphin to see what those icons I downloaded look like.

I just build the latest krusader-git (dev version 2.9.0) in aur, but alas, the problem is still there ! :frowning: