No HDMI signal on Nvidia RTX 4060ti on dual GPU setup (AMD)

Hello everyone,

I just completed the build of my first Linux PC with a Ryzen 7800X3D and a Nvidia RTX 4060ti. I am new to Linux and happy to learn a ton.

My current challenge is that I don’t get a video signal from the HDMI Port of the 4060 as my monitor shows “no signal”. I could not test the Display Ports yet. The HDMI Port of the Mainboard works (AMD).

Any idea what the issue might be? Thanks a lot in advance!

Here some info of my setup:

inxi -Fazy

  Kernel: 6.6.16-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=98ebed7a-8684-4b88-9462-a769d293f9d9 rw quiet
    root=/dev/mapper/luks-2bd03e44-60b7-47c1-8327-618c2d16a291 splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASRock model: B650E PG-ITX WiFi
    serial: <superuser required> uuid: <superuser required> UEFI: American
    Megatrends LLC. v: 1.07 date: 09/29/2022
  Info: model: AMD Ryzen 7 7800X3D bits: 64 type: MT MCP arch: Zen 4 gen: 5
    level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
    model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 96 MiB desc: 1x96 MiB
  Speed (MHz): avg: 595 high: 3532 min/max: 400/5050 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400 14: 400
    15: 400 16: 3532 bogomips: 134210
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA AD106 [GeForce RTX 4060 Ti] driver: nvidia v: 545.29.06
    alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2803
    class-ID: 0300
  Device-2: AMD Raphael driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-1,DP-2,eDP-1 bus-ID: 10:00.0
    chip-ID: 1002:164e class-ID: 0300 temp: 37.0 C
  Display: wayland server: v: with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
    gpu: nvidia,amdgpu display-ID: 0
  Monitor-1: HDMI-A-1 res: 2560x1440 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
    drv: nvidia device: 1 drv: radeonsi device: 3 drv: swrast gbm:
    drv: kms_swrast surfaceless: drv: nvidia wayland: drv: radeonsi x11:
    drv: radeonsi inactive: device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.5-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    raphael_mendocino LLVM 16.0.6 DRM 3.54 6.6.16-2-MANJARO)
    device-ID: 1002:164e memory: 500 MiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.276 layers: 1 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 4060 Ti driver: nvidia v: 545.29.06 device-ID: 10de:2803
    surfaces: xcb,xlib,wayland device: 1 type: integrated-gpu name: AMD Radeon
    Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv v: 23.3.5-manjaro1.1
    device-ID: 1002:164e surfaces: xcb,xlib,wayland
  Device-1: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s
    lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22bd class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.16-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak]
    vendor: Rivet Networks Killer driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>
  Device-2: Realtek Killer E3000 2.5GbE vendor: ASRock driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 07:00.0
    chip-ID: 10ec:3000 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-12:4 chip-ID: 8087:0032
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 14.25 GiB (1.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: MP700
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 126 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: EQFM22.3 temp: 43.9 C
    scheme: GPT
  ID-1: / raw-size: 931.21 GiB size: 915.52 GiB (98.32%) used: 14.25 GiB (1.6%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-2bd03e44-60b7-47c1-8327-618c2d16a291
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 448 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 39.1 C mobo: N/A gpu: amdgpu temp: 37.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 32 GiB note: est. available: 30.48 GiB used: 4.42 GiB (14.5%)
  Processes: 408 Power: uptime: 25m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.17 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1149 pm: pacman pkgs: 1143 libs: 327 tools: pamac pm: flatpak
    pkgs: 6 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.33

mhwd -l && mhwd -li && mhwd-kernel -li

                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-prime            2023.03.23               false            PCI
          video-nvidia            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:10:00.0 (0300:1002:164e) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-prime            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-prime            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
Currently running: 6.6.16-2-MANJARO (linux66)
The following kernels are installed in your system:
   * linux510
   * linux54
   * linux66

I switched to X11 and it did not work, but after I rebooted it did from the Nvidia card. Then I tried to reproduce it, switched back to Wayland, then to X11 again, but this time it did not.
It is the only setting I changed, but I could not reproduce it. It worked once from the Nvidia card.
Maybe this serves as a hint for someone.

Also, when I installed the system from a bootable usb stick, I selected the Nvidia drivers and it ran the monitor from the Nvidia card without any issues. Only after I booted into the installed system, it stopped working.

can you add version kernel 6.7 and retry and check ?

sudo mhwd-kernel -i linux67

Installed and running kernel 6.7, but no success so far.

for info you can remove kernel54 and kernel510 it cant work with Zen4
( version required 6.1 or 6.6 lts or more )

sudo mhwd-kernel -r linux54 
sudo mhwd-kernel -r linux510

which option have you chosen on install manjaro ,

  • free drivers or no free drivers ?

Thanks, was wondering why 54 and 510 did not work at all.

I chose the non-free drivers.

There will be a setting somewhere in your motherboard BIOS to prefer the discrete gfx card over the integrated gfx of the Ryzen 7800X3D. If that doesn’t work then try disabling the integrated gfx completely in BIOS.

Hmmm, not quite, I think you left out an important bit:

That’s the bios the board shipped with. You missed about 15 updates, fixes listed:

  • Improve GPU compatibility for GeForce RTX 40 series
  • Optimize dual graphics setting
  • Enhance iGPU performance
  • Enhance graphics card performance

On new hardware, this stuff matters.


Oh yea, that’s an important step indeed, thanks for pointing out.
Upgraded the BIOS to version 2.02 successfully, but still don’t get a signal from the Nvidia card.

Good. Have you had a look at the graphics-relevant Bios settings?

First, I enabled CSM, which seemed to have no effect.

Took me a while to find this setting, it is super hidden:

Advanced > AMD CBS > NBIO Common Options > GFX Configuration > iGPU Configuration >
I changed it from UMA_Auto to Auto and now I get a signal from the Nvidia card, BUT not on every boot which is odd. No signal from the iGPU anymore.

Got into the BIOS again, and it set it to iGPU Disabled automatically. The other options are UMA_Specified and UMA_Game_Optimized.

Any ideas how to reliably boot with the Nvidia card? Optimal scenario would be to use both GPUs.

That is likely to make your install unbootable if you have installed in Uefi mode.

Nope. You’ve got to try the available options (read the manual to find out what they do) and also keep an eye on future bios updates.

I based my tips on various reddit comments suggesting that there are still a number of bugs in the firmware of this board, hence the rushed-looking ‘beta’ versions available (btw, since you’ve found a work-around I’d wait 'till they’re out of beta). Your ‘Nvidia not on every boot’ issue was also mentioned and supports my assumption.

Disabled CSM.

Changed it to UMA_Specified and now I can’t seem to reach the BIOS anymore.

Thanks, I’ll keep trying.

I needed to clear the data in CMOS in order to be able to get into the Bios again.

there is screenshoot details on this page

it should show on boot menu
UEFI for your disk
CSM off Fast boot off

on Security menu
no Secure boot

and try on Advanced menu TPM
Security Device Suppot disabled

and advanced PCI configuration
above 4G and bar support enabled

if UEFI , all Disk should be in ACPI mode ( not raid mode )

Set everything accordingly. Fast Boot and Security Device Support were enabled, now disabled.

UMA_Specified worked with iGPU this time and boot screen, but not the Nvidia card (UMA Frame Buffer Size: 2G).

iGPU Disabled same as before: Works only when I (1) connect the monitor to the mainboard, (2) try to boot (doesn’t work of course), (3) shut machine off, (4) connect monitor to Nvidia card, works. I have to do step 1 and 2 each time when using the Nvidia card.

Now, UMA_Game_Optimized works with iGPU every time and when doing the back and forth plugging of the monitor, the Nvidia card works as well. So its almost there…

so to summarize:

  • your igpu amd cpu can be disabled, it needs to share a part of the memory for video, you use the video ports of the motherboard ( on a dedicated pci number )
    UMA Frame Buffer ( for Igpu memory ) and
    specify to go beyond 4G and use the Rebar option

  • for the Nvidia card, it’s based on a dedicated PCI port, and if you ask to be specified at UEFI level, it uses the video card’s ports.
    still needs to be specified to go beyond 4G and use the Rebar option

UEFI asks which one you’re using for video output at boot time.

you have 2 options

  • either use only the Nvidia car, in which case you’ll only have the Nvidia driver,

  • or use Igpu and Nvidia. By default, Igpu is used for the graphical interface, so you need to check whether prime / offload Nvidia can be launched.
    to have hybrid amd and nvidia drivers, which has implications for
    -mesa , vulkan , and videos

for hybrif and prime see this

I decided to go with the Nvidia card only which means that I have only installed the Nvidia drivers rn.
In the bios I disabled the iGPU, but still need to do the port switching at startup to be able to drive the monitor.

I reinstalled Manjaro and now all of a sudden everything (Nvidia card only and iGPU disabled) seems to work. I fire up the machine and it’s able to drive the monitor without any of the switching.

It is not entirely satisfactory as I don’t know the reason and proper solution… maybe the update of the bios for the mainboard had some positive effects on the installation process idk. One thing I did differently this time was that I did not encrypt my disk.

Nevertheless, thank you all for your support, I appreciate it.