No HDMI out on Tiger Lake laptop

Mod-edit: Formatting

I am currently facing an issue where I don’t exactly know what the root cause is but closest I can think of is this section.
So I recently bought me a new laptop, a “Lenovo Yoga Slim 7 (14ITL05)”.
I am running “Linux laptop 5.10.0-1-MANJARO” as a kernel, otherwise Manjaro stable.
From the inside this laptop is on the Intel Tiger Lake platform with the integrated “Xe” GPU. Everything runs mostly fine but I cannot figure out how to get HDMI out working on the laptop.
It definitely worked with Windows 10 which was what the system came installed with.
xrandr shows:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm 1920x1080     60.05*+
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

This is weird because the laptop has 2x Thunderbolt4 but it shows 3x DP connectors so perhaps that is already detected wrong.
It definitely has a dedicated HDMI port and 2x DP but not 3x DP.
I do get messages regarding HDCP in my journal so their is something happening when it comes to HDCP I guess:

laptop kernel: mei_hdcp 0000:00:16.0-b638ab7e-94e2-4ea2-a552-d1c54b627f04: bound 0000:00:02.0 (ops i915_hdcp_component_ops [i915])

I also see HDMI mentioned by aplay:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sofhdadsp [sof-hda-dsp], device 0: HDA Analog (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 1: HDA Digital (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 3: HDMI1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 4: HDMI2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 5: HDMI3 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I know that there are other laptops with Tiger Lake and it seems that at least one of them has working HDMI out, but I got in contact with that person and she is new to Linux so that makes debugging a little cumbersome and honestly I don’t know where to look, to be honest.

Is this an i915 issue?
Do I need to test with different parameters?
Which could/would that be?

Any help would be appreciated, thanks!

Hi and welcome to the forum :+1:

I adjusted your formatting and category a little bit to make it more readable for those that are able to help :wink:

Thanks! I used the preformat option while creating the post but it didn’t stick with the formatting.

I guess it’s not impossible that the HDMI is internally converted to a display port, that’s why the GPU sees it that way. Anyways, if you start sudo dmesg -w, then proceed to connect a monitor, does it generate any (relevant) output? Does audio work over HDMI?

I checked that before and just did another run: it doesn’t do anything in dmesg, sadly.
The monitor does something at least, going from “check video cable” to all black if I connect the cable but afterwards goes to “check video cable” again.
I also checked Xorg.0.log with a tail -F but that also did not show anything, sadly.

I think I found the issue:
dmesg is reporting this:

[drm:lspcon_init [i915]] *ERROR* Failed to probe lspcon
i915 0000:00:02.0: [drm] *ERROR* LSPCON init failed on port B
[drm:lspcon_init [i915]] *ERROR* Failed to probe lspcon
i915 0000:00:02.0: [drm] *ERROR* LSPCON init failed on port D
[drm:lspcon_init [i915]] *ERROR* Failed to probe lspcon
i915 0000:00:02.0: [drm] *ERROR* LSPCON init failed on port E

Searching on the internet it seems that a chip is responsible to convert the DP signal to HDMI and that one has to update Intel’s i915 or drm or whatever it needs to address this issue.

This issue seems to be similar, and it suggests that it could work if you connect the cable before booting. Can you test that?

I saw that, too, and it does not make a difference for me, it does not work either way. But I guess I will have to open an issue there.

Edit: I am trying my luck with linux-drm-tip-git from AUR now.

Just some more reference info:

I recently bought a Lenovo Thinkbook 14 Gen 2.

It has the onboard Intel Iris Xe graphics.

I have a 4K external monitor (ViewSonic VP3268-4K PRO 32").

When I first tried the 14.g2 under Windows 10, I could get no picture over HDMI (1.4b) to the monitor - not even 1024x768. HDMI seamed to be completely dead. I also verified this with a second laptop, bought by a friend.

So I tried a USB/Thunderbolt to DP cable, and I could get 4K (3840x2160) but only at 30 Hz.

Then, I swapped out the SSD, installed the latest Manjaro, and tried again.

HDMI: best was 1024x768 at 60 Hz

usb-DP: best was 2560x1440 at 30 Hz (corrected my mistake of: 60 Hz)

I have since returned the laptop - so I can’t run any tests for you.

Another reference - I also have the Lenovo Thinkbook 14 (gen 1).

That has Integrated Intel UHD Iris Plus Graphics G4 (Ice Lake 48 EU).

The HDMI (1.4b) can drive the 4K monitor, 3840x2160 at 60 Hz.

And I also have the option to do 4096x2160 at 60 Hz.

So my questions are:

Should Intel Xe graphics be able to do full 4K at 60 Hz?

Shouldn’t the ‘newer’ graphics (Xe) be better than the previous generation (UHD Iris Plus)?

Is it a problem with the Lenovo implementation, or the new Xe graphics?

Please open your own thread regarding your issue.

Do not necro bump a thread.

1 Like

I don’t have an issue.

I’m trying to add information to help the poster.

Should I not bother?

Maybe I misread this as asking for help.

Yes, you did.

Those are my thoughts/question, in the form of a muse, for anyone else to give some input on.

I don’t consider myself an expert on this subject.

So to help progress the subject - it may be useful for someone else to address those questions.

And, I don’t think the thread was dead.

There is no marked ‘solution’ post, the poster has not indicated that they have solved the problem, and it is not closed.

Now, I could have miss-interpreted the original question/problem.

Is it that they don’t know how to turn the HDMI port on, or is it that the port is on, but not working as expected?

For my case, it was the latter.

Past tense, because: