No GUI. startx error. Failed to start LDM

Hello everyone,

I’ve run into a serious anomaly. This if for the MNJ-ARC KDE.

Upgraded my gfx card from an RX 480 to a RX 7600. During this time, my PC was dormant for 4 months.
Obviovsly, couldnt perform any updates etc…

This was due to a motherboard 12v short, that in turn also shortrd my Corsair 750 W PSU. And since I was getting a new PSU, I decided to get a new gfx card as well.

After upgrading the gfx card, I tried to boot to MNJ (I have a dual boot setup. Both OS’es boot from their individual hard disks.

I see the screen of the (xxxx/xxxxx) files cleaned & so on, but the graphical interface doesnt load at all. The terminal is accessible via ALT+F2, F3,…

I had also noticed an xserver error.

Upon startx, it returns with:
init: giving up
unable to connect to X server: Connection refued. (attached).

I then decided to boot MNJ through a LIVE ISO setup. Its an older image I had burnt on an USB.
Still did not go all the way through. The LIVE-ISO screen freezes on:
‘failed to start Light Display Manager’

My Windows 10 boots just fine.

Please let me know if I can provide with more details.

Could anyone help me with this situation? That’ll be great!

What sort of an inconsistency is this? Very strange!

Moderator edit: Removed useless images

Please, no unnecessary pictures, for the first one you could have copied the text and post it. :wink:

Okay. Noted for future reference.

But, I still need a solution.


I had a couple of months off my main machine a while back… I’m not sure if anyone’s going to chime in here with a quick dirty fix - I’d probably be lazy to recover it and opt to go with a fresh installation and recover settings from the last backup.

If you don’t have that, then you just learned the lesson - and can appreciate why I always check that I have BTRFS snapshots running to keep a couple of ‘instant’ snapshots on my main disk, as well as an rsync backup to keep something more wholesome on my storage disk.

Failing this, get yourself a fresh ISO, and use that to recover any valuable stuff from your existing system before doing a clean install.

You may need to reconsider the kernel of choice - I have seen quite a few topics where the solution was to change to a newer kernel.

Kernel 6.1 may be adequate but kernel 6.5 or 6.6 is better.

Lightdm is not a default for Plasma but SDDM is.

When you try replacing the default display manager or as others would call it login screen it is imperative that you understand the process.

The thing with display managers is - they need configuration - in this case you need to edit the default session started by LightDM.

Another thing is a theme - lightdm package doesn’t default to a theme - you need to install a greeter-theme package - then you need to configure lightdm to use that theme.

Thanks for replying.

I’m keeping the format/fresh install step as the last one.


Pardon my noob-ishness, but how do I choose a specific kernel?
Is it when downloading a fresh image from this page:

Or how exactly I do that?

If you could briefly explain the process, that’ll be just great!

How exactly do I edit and which file(path) is it?
What would be its parameters?

But I did not have to do this during my initial MNJ install?
Which theme package do you suggest?

I’m in a mess and need all the help I can get.

Thank you for your patience.

Have you tried chrooting into your installed system and running the upgrade from there?
manjaro-chroot -a
sudo pacman-mirrors -f
sudo pacman -Syyu (I think the second “y” might be needed)
Pacman may report errors due to the installation being stale (dependency issues etc.). In that case, you can try adding the --nodeps option.

Then assuming you still need SDDM for it to work, it can be installed as per the Arch Wiki:

I see you’ve been around here for over 3 years. I would think you would know that all your questions are answered in either the Manjaro or Arch wiki’s, or with a simple Google search.

The what now? :thinking:

Sorry, there’s nothing obvious here.

Please help us help you. See:

BG405, I will try that.


Hi ydar!

I did search for the links and google prior making a post here.

I still assume its specific to my gfx card, hence I seek a more concise solution.


There is a lack of information and a lot of similarity with an xyproblem - where you seek solution for a failed attempt to solve which makes it inherently difficult to understand and difficult to provide any meaningful response

  • why is it you are referring to LightDM display manager when using Plasma?
  • did you manage to LightDm working before the change of hardware
  • what is the output from (as text please - with codefence - not quote - but codefence)
    inxi -Fc0

Assuming you had the unusual lightdm working as displaymanager for plasma before the change of hardware - so I won’t say anything about that.

  • Download the latest ISO.
  • Write to USB
  • Boot your system using the USB
  • Mount your system’s partitions
  • Use chroot to repair your system e.g.
    sudo manjaro-chroot -a
    Inside the chroot
    pacman-mirrors --continent
    pacman-mirrors -G
    Depending on the branch
    • stable
      pacman -Syu linux65 linux65-headers
    • unstable or testing
      pacman -Syu linux66 linux66-headers
  • Exit chroot

Finally reboot your system

1 Like