No graphical login screen with Nvidia driver on Linux-6.1

Issue: No graphical login after installing NVIDIA drivers
Hardware: Intel CPU, NVIDIA 9800GT (Driver: 340.108, 64-bit – Driver code name: Tesla)
Software: Stock install of Manjaro-KDE Plasma 22; Linux61, Linux60-rt, X11 Server
Recovery: Drop to shell (Fn+F3), timeshift --restore; revert back to Nouveau drivers for full functionality
Objective: Install proprietary NVIDIA drivers to use Kernel-rt without system freezing

Issue description:
I have followed the steps to install Nvidia drivers on my hardware with the latest Manjaro distribution without any success. I am able to choose between the two kernels that I have installed in my system, and 6.0.5-rt14-2, with the same symptoms. I am not able to see the window manager load up; the process hangs on the black screen with the three dots cycling, then stops. I am able to recover from this situation by switching to a non-graphical shell and perform a full restore to the previous Nouveau driver installation (command to restore: timeshift --restore).

I used the instructions from

$sudo mhwd -a pci nonfree 0300

Everything installs without any errors, but no graphical login screen.


  1. Is the Nvidia driver 340.18 compatible with kernel module for the linux 6.x series?
  2. Are there any kernel boot parameters required to either suppress the old Nouveau driver or set Nvidia driver parameters?

The primary reason to switch from Nouveau to Nvidia driver is to be able to use kernel-rt reliably, without the screen freeze I have been experiencing with Nouveau. With regular Kernel the system is rock solid.

So, please help with identifying a solution to use the Nvidia driver.

can you provide

inxi -Fza
sudo mhwd-kernel -li

Have you tried to add
to the grub boot line? It’s needed for some recent nvidia drivers in 6.x kernels to properly boot. Perhaps is what you need!

$inxi -Fza
Kernel: 6.1.1-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
root=UUID=a0096517-a002-4adb-8b56-8ffddb05d4d0 rw quiet splash
udev.log_priority=3 threadirqs
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Manjaro Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: P6T DELUXE v: Rev 1.xx
serial: BIOS: American Megatrends v: 1701
date: 09/02/2009
Info: model: Intel 000 bits: 64 type: MT MCP arch: Nehalem level: v2
built: 2008-10 process: Intel 45nm family: 6 model-id: 0x1A (26) stepping: 4
microcode: 0x12
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3201 min/max: 1600/3201 boost: enabled scaling:
driver: acpi-cpufreq governor: performance cores: 1: 3201 2: 3201 3: 3201
4: 3201 5: 3201 6: 3201 7: 3201 8: 3201 bogomips: 51337
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA G92 [GeForce 9800 GT] vendor: BFG Tech driver: nouveau
v: kernel non-free: series: 340.xx status: legacy (EOL) last:
release: 340.108 kernel: 5.4 xorg: 1.20 arch: Tesla process: 40-80nm
built: 2006-13 pcie: gen: 2 speed: 5 GT/s lanes: 16 ports:
active: DVI-I-1,DVI-I-2 empty: none bus-ID: 02:00.0 chip-ID: 10de:0605
class-ID: 0300 temp: 63.0 C
Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
loaded: modesetting alternate: fbdev,vesa dri: nouveau gpu: nouveau
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3520x1080 s-dpi: 96 s-size: 931x285mm (36.65x11.22")
s-diag: 974mm (38.33")
Monitor-1: DVI-I-1 pos: primary,left model: Asus VH238 serial:
built: 2010 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
size: 509x286mm (20.04x11.26") diag: 584mm (23") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: DVI-I-2 pos: right model: Acer S201HL serial:
built: 2011 res: 1600x900 hz: 60 dpi: 92 gamma: 1.2
size: 443x249mm (17.44x9.8") diag: 508mm (20") ratio: 16:9 modes:
max: 1600x900 min: 720x400
API: OpenGL v: 3.3 Mesa 22.3.1 renderer: NV92 direct render: Yes
Device-1: Intel 82801JI HD Audio vendor: ASUSTeK driver: snd_hda_intel
bus-ID: 6-2:2 v: kernel bus-ID: 00:1b.0 chip-ID: 0944:0117
chip-ID: 8086:3a3e class-ID: 0103 class-ID: 0403
Device-2: Creative Labs EMU10k1 [Sound Blaster Live! Series]
driver: snd_emu10k1 v: kernel bus-ID: 07:00.0 chip-ID: 1102:0002
class-ID: 0401
Device-3: VIA ICE1712 [Envy24] PCI Multi-Channel I/O driver: snd_ice1712
v: kernel bus-ID: 07:01.0 chip-ID: 1412:1712 class-ID: 0401
Device-4: KORG nanoKONTROL2 MIDI Controller type: USB
driver: snd-usb-audio
Sound API: ALSA v: k6.1.1-1-MANJARO running: yes
Sound Server-1: JACK v: 1.9.21 running: no
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.63 running: yes
Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
chip-ID: 168c:002b class-ID: 0280
IF: wlp3s0 state: up mac:
Device-2: Marvell 88E8056 PCI-E Gigabit Ethernet vendor: ASUSTeK
driver: sky2 v: 1.30 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: b800
bus-ID: 04:00.0 chip-ID: 11ab:4364 class-ID: 0200
IF: enp4s0 state: down mac:
Device-3: Marvell 88E8056 PCI-E Gigabit Ethernet vendor: ASUSTeK
driver: sky2 v: 1.30 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: c800
bus-ID: 05:00.0 chip-ID: 11ab:4364 class-ID: 0200
IF: enp5s0 state: down mac:
Local Storage: total: 4.26 TiB used: 186.65 GiB (4.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDP064G
size: 58.69 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: SSD serial: scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SHFS37A120G
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: SSD serial: rev: BBF0 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST4000DM006-2G5107
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: rev: DN04 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST3500630AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
type: N/A serial: rev: K scheme: MBR
ID-1: / raw-size: 58.69 GiB size: 57.47 GiB (97.92%) used: 12.04 GiB (20.9%)
fs: ext4 dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 3.64 TiB size: 3.58 TiB (98.40%)
used: 174.61 GiB (4.8%) fs: ext4 dev: /dev/sdc1 maj-min: 8:33
Alert: No swap data was found.
System Temperatures: cpu: 44.5 C mobo: 45.0 C gpu: nouveau temp: 63.0 C
Fan Speeds (RPM): cpu: 1506 psu: 0 case-1: 0 case-2: 0 case-3: 0 fan-1: 0
fan-2: 0 fan-3: 0
Power: 12v: 12.19 5v: N/A 3.3v: 3.28 vbat: N/A gpu: nouveau mV: 950.00
Processes: 229 Uptime: 4h 59m wakeups: 0 Memory: 5.78 GiB
used: 1.86 GiB (32.1%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 1207 libs: 329 tools: octopi,pamac,yay pm: flatpak pkgs: 0 Shell: Zsh
v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24

Yes, I tried that on the 5th instance of the install, restore cycle, with same results.

Almost about to give up on the NVIDIA driver, just out of exhaustion after 12 restores. Now mhwd complains NVIDIA driver is already installed and it refuses to install, even though I restored my Nouveau driver setup.

you are using an old nvidia card that is no longer supported with manjaro and other distros, which means there are no available nvidia drivers… you can install them manually from aur for example, search in the forum for topics related to installing the 340 nvidia drivers…

1 Like

That makes sense. I will search AUR forums. Thanks

i meant to search in this manjaro forum…

Got it; I will search on this forum. One question: if I manually install, would I able to compile against kernel 6.0 and 6.1? If I upgrade to a newer kernel is it just a matter of recompiling the modules?

with these 340 drivers i dont know how it works, they are old and no longer supported, but it shouldnt be a issue, if you install kernel headers + dkms nvidia drivers, but again search on this forum, on how to properly install them…