No Google drive integration in Nemo or Nautilus

Google accounts set up in online accounts work fine, apart from Google drive. Nothing is mounted in Nemo and this integration just generally seems missing.

I know I can use something like OCamlFUSE, but the normal Online account integration is a lot less hassle when it works

I wrote a how-to for this a couple years ago. You have to install a couple additional packages. I’ll look on the old forum and try to find it.

Here is a how-to, for Cinnamon. Written two years ago, but should still be accurate enough to get you on the right track.
https://archived.forum.manjaro.org/t/howto-google-drive-integration-into-nemo-cinnamon-3-6/36890

1 Like

@oberon should these be included in the cinnamon edition by default?

gvfs-goa gvfs-google
1 Like

Unfortunately they aren’t but I’ve just installed them on Cinnamon and it works like a charm

Brilliant. I’ll give that a go.
I’m getting errors in Geary related to Goa, so that makes sense

I know. By I’m suggesting that they should be :slightly_smiling_face:

1 Like

That worked :+1:

Out of curiosity, I had a look at Mint in a VM and it has the same issue, so we can’t be too hard on our lovely Manjaro community :slight_smile:

1 Like

No luck here. I installed gvfs-goa and gvfs-google. I go to System Settings and click Online Accounts:

I click Sign In:

google2

I enter my account name and password… and the goa still wants me to log in to my Google account. If I delete the account, I get:

google3

I have tried running “gnome-keyring-daemon -r” and “gnome-keyring-daemon --replace –components=secrets” with no change.

Any help would be greatly appreciated.

You probably want to start from scratch. Find the folders that hold the account data, including those in apps that use the accounts, like Geary, and delete those