No extension named Copilot on VSCode installed from community repository

I have VS Code installed from Official Community Repository, version 1.64.0-1. I cannot get to install the Github copilot extension in vscode. Searching for copilot returns no results, where the tar.xz package downloaded from VSCode’s website returns the desired extension, which I can install successfully. But the tar.xz package is a portable version of VSCode and I need to log in every time. I have learnt from another thread that code-oss searches from a different registry, so how do I install copilot on Code-OSS?

I recommend installing this aur.archlinux.org/packages/code-marketplace
it’s basically script that edites product.json for code-oss aka changing the registry it searches through but it’s not guaranteed the extensions will work but as far i know copilot works okay

I have solved the problem by installing visual-studio-code-bin package from aur.

For others dropping by - here’s a short explanation

The issue is because the open source version - which is the one in the repo - differs from upstream as many of the proprietary features - such as telemetry/tracking/logging/feedback etc. - has been disabled or removed.

There is a few custom packages available from AUR - among those the Microsoft version - which most likely has all features enabled.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.