No Desktop on Start from Stick


I’m trying to install manjaro xfce on a Fijutsu Siemens Esprimo Mobile. Booting from USB-Stick leads to “Reached target Graphical interface” but no Desktop.

I can login on TTY2. “startx” gives “no screens found”

what can i do?


Hello @rob_42 :wink:

First step:

Have a look at the Xorg log and figure out which driver does not load and why:

cat /var/log/Xorg.0.log | less

Hello megavolt,

there doesn’t seem to be a Xorg.0.log … “find” can’t find it …

(by the way, i tested the Stick on an Asus machine and everything worked fine …)

@rob_42 sorry wrong path :sweat_smile: I corrected it:

@megavolt excuse my responding-time … it’s not the higest priority to get the Computer running right now … but i want to do it!

Well, however I can’t find a Xorg.0.log - file

find / -name Xorg.* | more

doesn’t show a Xorg.0.log

searching a bit on

wiki.archlinux.XX (.org gives some error i don’t really understand …)

i tried:

lspci | grep -e VGA

with the information

01:00.0 VGA( …) [SiS] 771/671 PCIE VGA Display Adapter (rev 10)


xdpyinfo | grep -B2 resolution


unable to open display

(maybe because there’s no display defined?)

Can you give me some more hint what may help?

Puh… that is an old one. The driver for this card is not there at the official sources, but there still an AUR Package, which needs to be compiled. No idea if it works with the newer kernels.

So i guess without a modified ISO image, you will not be able to boot in graphical mode (text mode will still work). Better use another Distro which has the SIS driver (maybe debian?) or maybe try to install archlinux and compile the driver there…

Hello megavolt,
following your hints i tried to install a Xubuntu. And well, it’s running on 680x480 … I think i have to learn something about the Xserver if i really want to run this old one …

thanks so long

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.