No desktop just blank screen

I restarted system and saw just black screen and autostarted apps. alt + tab combo works but tooks a lot of time. I tried plasmashell --replace & which never responds and closes himself after hitting enter (I waited 5m).

This is the first time Im using the forum and arch family linux also kde also manjaro.

I tried to upload photo; Sorry, you can't embed media items in a post.

I checked task list, Im seeing plasmashell running but doing nothing. I tried to kill it and restart by plasmashell command but no luck

First, you need to provide information from the output of running inxi -Faxy.

But given that you can only access by terminal (lacking the copy paste), maybe you can connect a USB removable thumb drive and run inxi -Faxy > PATH_TO_MOUNTED_REMOVABLE_DRIVE/temporary_inxi.txt. Then use your current device to access the “temporary.txt” and copy paste the output here.

Also the output of sudo demsg > PATH_TO_MOUNTED_REMOVABLE_DRIVE/temporary_demsg.txt when you start the system.

My first thought is that this is either X server or graphics driver problem.

i hope you are not in a tty Linux console - ArchWiki.

share some system info →

Given his condition is in black screen and autostarted apps, probably there’s a need to access tty by Ctrl+Alt+F1-6.

Thanks a lot for responding so quickly. Here is my output from inxi -Faxy

Edit: I managed to run firefox from terminal. I think every application except ui works

  Host: Desktop Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.1.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=b1987845-317c-4c87-bc5c-feaba12c0805 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: A320M-A PRO (MS-7C51) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.30
    date: 11/08/2019
  Info: model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2628 high: 4349 min/max: 2200/4409 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2190 2: 2156
    3: 4349 4: 2190 5: 1922 6: 2465 7: 3480 8: 2175 9: 4346 10: 1867 11: 2199
    12: 2199 bogomips: 91245
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ASUSTeK driver: nvidia
    v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 29:00.0 chip-ID: 10de:1c82
    class-ID: 0300
  Display: x11 server: compositor: kwin_x11 driver:
    loaded: nvidia resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 29:00.1 chip-ID: 10de:0fb9
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 2b:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Device-3: Barco Display Systems USBZH5XK-ENC type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2:2 chip-ID: 0600:aa16
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 25:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: 2c:f0:5d:09:b7:b5
  Device-2: Ralink RT2070 Wireless Adapter type: USB driver: rt2800usb
    bus-ID: 3-3:3 chip-ID: 148f:2070 class-ID: 0000 serial: 1.0
  IF: wlp43s0f3u3 state: down mac: aa:62:b6:9c:8b:fb
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 3-4:4 chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 689.33 GiB used: 75.78 GiB (11.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: S3YANB0NB38951V rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SSD PLUS 240GB
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: 21011B805314 rev: 04RL scheme: GPT
  ID-1: / raw-size: 223.27 GiB size: 218.71 GiB (97.96%)
    used: 75.78 GiB (34.6%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 48 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 328 Uptime: 1h 3m wakeups: 1 Memory: 15.64 GiB
  used: 2.96 GiB (18.9%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: 1306 pacman: 1298 lib: 346 flatpak: 0
  snap: 8 Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.11

Did this happen after a system update?

From the output of the UEFI version:

  Type: Desktop Mobo: Micro-Star model: A320M-A PRO (MS-7C51) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.30
    date: 11/08/2019

The UEFI is already old and you need to check for UEFI update from the vendor website.

Other than software updates, BIOS/UEFI also needs constant monitoring for manual update.

I never did a system update. I installed os like two days ago. I’ll try to update uefi

I found a solution

rm ~/.config/plasma-org.kde.plasma.desktop-appletsrc

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.