No Cyrillic in Okular

Okular does not show Cyrillic letters, even though other programs can and I set the fall-back language to Russian. I cannot install language packages via Manjaro settings, because the button is grayed out.

Does anyone know what is going on or even better, a fix?
Thanks in advance.

This would seem related to be a long-standing bug: Okular does’t show a text with cyrillic symbols in comments.

KDE Plasma; KDE Frameworks; QT.

This ofcourse does not explain why the option to install languages is greyed out.

Thank you, @soundofthunder

My problem is with the main text in the document, not commentaries, but it might be the same root problem. This might become a deal breaker. That’s a pity, I love Okular.

That being the case, it might then be attributable to the font used for your document.

Does the font support Unicode to the extent that it will display Cyrillic characters? If it doesn’t, then choosing a font like Noto or Microsoft’s Arial Unicode family (which, from memory, are fully supportive of Unicode), might solve it.

Beyond that, I have nothing more to suggest. :person_shrugging:

Aside:- I’ve learned to become a KDE fan-boy in many respects. However, despite having a great admiration for Okular as a part of the KDE ecosystem, I haven’t yet been able to adapt it to my personal work flow. There are too many alternatives that I’m already accustomed to, I suppose.

It is not a document, I have created myself, so … I guess I have no power over which font it uses. :person_shrugging: But thank you!

If the font is somehow embedded, as can be the case with PDF files, then this is probably true.

Changing the default font used for a particular Okular backend might also be worth investigating.
( Settings → Configure Backends )

Can you provide a document you’re having troubles with?

It’s here. My browser cannot read it either. I don’t remember if it cold read it before or not. I think I was using a different browser that doesn’t load a preview.

I don’t see any meaningful characters either. This file expects Helvetica font and uses WinAnsi encoding

pdffonts dok_0009_ucr_ru.pdf
name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
Helvetica                            Type 1            WinAnsi          no  no  no       9  0
Helvetica-Bold                       Type 1            WinAnsi          no  no  no      10  0

Not sure if anything could be done to make it readable

German version of the same document: dok_0009_ucr_de.pdf.

Вы, скорее всего, можете перевести текст с немецкого на русский с использованием ‘Google Translate’, например:

“Декрет о распуске Учредительного собрания, принятый 6 (19) января 1918 года, является ключевым документом в истории Русской революции.”

Hello @soundofthunder.

I know about the German version and I have used it in my paper, but in science, you want to go to the original source. I just wanted to read the original in Russian too and quote it.

@Xephon, no idea, but I just ended up quoting the German version. :person_shrugging: The second I read “Win” I lose all hope :laughing: