No brightness control laptop hybrid Intel/NVidia and kernel 5.10.2-2

  • Hardware: laptop with hybrid video Intel / NVidia
  • Driver: linux510-nvidia 455.45:01-10.0
  • Kernel: 5.10.2-2-MANJARO

Can’t control anymore the brightness with linux510.
linux58 had no problem and I run linux54 fine too.

Keys to control the brightness are inefficient, as the command xbacklight!

When I run linux54, there is a /sys/class/backlight/nvidia_0/brightness and the brightness control works OOB.
When I run linux510, there is a /sys/class/backlight/acpi_video0/brightness and the brightness control doesn’t work :unamused: and the nvidia driver is in use.

Tried any kernel parameters…


Tried too Option "RegistryDwords" "EnableBrightnessControl=1" within /etc/X11/xorg.conf/90-mhwd.conf with no succes.

A suggestion ?

I’m also facing similar situation after latest stable update. Tried every solution posted on different forums also but none worked.
Some common solutions are given in this post Can't adjust screen brightness (Lenovo Laptop, NVIDIA, XFCE) but it didn’t work.

After setting kernel param acpi_backlight=vendor, this path is accessible /sys/class/backlight/ideapad/brightness

Anyone having solutions to fix the problem with brightness control?
Is it a kernel issue or driver problem?


Similar issue cropped up at other forums like one below but still people are looking for solutions.
Kernel 5.10: backlight brightness control not initialised / Laptop Issues / Arch Linux Forums

I guess the current best solution is to downgrade to kernel 5.9.x

Issue solved with kernel 5.10.7-3-MANJARO :smiley:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.