No bootable device?

Hi to the manjaro community!

I am glad to say I dared to create a profile here. I’m not the most social guy, but hey, hopefully we will find and help each other throughout this journey.

I recently got myself into the world of Linux. Started college some months ago, and I have been wandering around the immensity of linux by myself.

I finally decided to land on Manjaro KDE, mostly because I wanted to try something different. It’s AUR support, and unique hardware detection got me tangled to it.

It has felt fantastic to port this Linux flavour with my former(daily usage) laptop.

I ran into a problem. For school I need to have an Ubuntu Linux distribution, and even though VM and web versions of Linux exist, I decided to go and get myself a 128GB USB stick, make another (lighter) USB stick bootable and install it on the aforementioned one. The idea was making half of the stick available for Ubuntu MATE, and the other half for Windows 7.

I thought this had gone well. Until it did not. I forgot to switch from UEFI to Legacy BIOS, and since Manjaro had also been EFI-installed on my hard drive, I ran into a problem.

Once the installation was over, I could not boot again into Manjaro nor into Ubuntu. The error I get is “No bootable device”

Now, in order to install Ubuntu on my USB stick, I saw the swap partition from my hard disk (which I did not intend to use for this OS) had to be formatted again.

I do not know if that could be a problem when it comes to booting from different disks.

The moment I saw this appeared to be unsolvable, I tried reinstalling on EFI one more time, this time switching the master boot installation to my hard disk. So Ubuntu MATE on my USB stick, and the bootloader on my hard disk. But this did not solve it either.

Now I am currently waiting for Ubuntu to finish the installation in Legacy mode.

My next step would be burning Manjaro’s ISO back into a second usb stick, and choosing for a reinstall. I do not want to get over losing all my configs again.

Any help will strongly be appreciated.

Thanks for taking the time to read my small, amateur but pleasant journey through the world of Linux.

UPDATE: The BIOS installation of Ubuntu has completed, I now have a grub that boots into Ubuntu, but Manjaro still cannot be accessed from here.


EDIT!: I managed to solve it by booting into the BIOS, changing Legacy to UEFI again, turning Secure Mode on, and finally putting hdd/manjaro/grubx64.efi as trusted device.

This was a fun thing to do, and a little bit challenging for me. But now it has been solved, by myself!

Hope this will help in the future.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.