No boot after clearing cmos, select proper boot device


When I was plugging in some cables (lan,audio) at the back of my pc I accidentally pressed the clear cmos button while the pc was running. Now my pc won’t boot and this message is displayed:

Reboot and select proper boot device. 

I have checked all settings in uefi and they are restored to previous conditions except for one. Under boot devices there is no longer a ‘‘manjaro’’ entry. Using a live usb I have tried:

sudo update-grub
/usr/bin/grub-probe: error: failed to get canonical path of `overlay'.

And Gparted shows all partitions on the ssd. I am at a loss now and quite frankly I find it very strange that clearing cmos will fail a pc from booting correctly even after manually restoring the settings. My pc:

  • asrock z77 extreme4 (latest firmware and there is no legacy bios option)
  • samsung 870evo (brand new)
  • btrfs (installed in efi mode and gpt)

Can anyone help please?

Btw I have a older clonezilla backup, not tried it yet.

:thinking: You obviously didn’t restore everything. Clearing the CMOS does just that…it’s not a partial clearing.

Re-install GRUB:


Booted from live media and selected:

Detect efi bootloaders

Then selected the following:


Booted in my system and reinstalled grub and grub btrfs in pacman. Still the same error.

Did some searching and found this command:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --recheck

Suggested by this post:


That fixed it. Thanx for your input.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.