No battery icon in system tray

Hi,
Battery icon is missing in my system tray. I can make it reappear by disabling and reenabling, using “configure system tray” . There is no other issue, i.e. brightness keys and power info in system settings works as expected. I like to adjust brightness by rolling mousewheel over it, so I want to have it there easily :slight_smile:
Is there a way to find what is the problem?

Have you looked in the list of widgets that you can put on the panel? I’m sure there’s a battery icon widget in there, so that you don’t have to rely on it via the system tray. That way you can disable the one in the tray and put the standalone widget wherever you like it.

Right-click the desktop and choose “Enter Edit Mode”. Then right-click the panel and choose “Add Widgets”.

Thank you for your quick reply.
Yes, there is the exact same widget to put on the panel. But it will sit under or above the system tray, not to the place where I used to see it. Or I can just continue to disable and enable it after boot, not so big work :slight_smile:
I just wondered if there is a way to deal with the issue.

If you right-click the system tray and choose “System Tray Settings”, and you move to the Entries section, is the battery icon set to “always visible”?

yes, either “always shown” or “shown when relevant”. Changing other visibility options doesn’t work, I have to choose “disabled”, apply it and choose “always shown” or “shown when relevant”.

Was this after todays update? Mine seems to disappeared also!

No, it was exist before. I don’t know when it started.

Edit: I added sleep 30 to the Exec= line of /etc/xdg/autostart/powerdevil.desktop file. The line is shown as:
Exec=sleep 30 && /usr/lib/org_kde_powerdevil

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.