No background changing over the folders

after updating to plasma 6 is the desktop there is no selecting background changing to let me know that i’m choosing a folder:

in dolphin browser:

how to fix this?

Remove old Plasma config.

1 Like

Cant reproduce.
If all else fails and things are ‘weird’ from the upgrade then make sure to ‘refresh’ the configs.

kbuildsycoca5 --noincremental                                                          ✔ 
kbuildsycoca5 running...
kf.service.sycoca: Service type not found: "application/org.kiwix.desktop.x-zim"

should i remove the whole plasma config folder?

You probably have something like that in your ~/.config/mimeapps.list
(should you? do you have kiwi something? I dont know)

What do you think that is?
(probably ‘no’ to that)
Did you follow all the steps above?
If you did … that should be pretty close to a full plasma desktop configuration reset for that user.
Remember to restart afterwards.

yes i have followed all the steps
i restarted and i see that the icons and the background are changed but the problem is still occuring.

i have kiwix installed

Then rename .config/dolphinrc and reboot.

i did and restarted but the problem still exists
i think that the problem is not in the dolphin but in the plasma desktop

It seems to have changed to kbuildsycoca6.


1 Like

kbuildsycoca6 --noincremental  :heavy_check_mark:
kbuildsycoca6 running…
kf.service.sycoca: Service type not found: “application/org.kiwix.desktop.x-zim”
kbuildsycoca5 --noincremental  :heavy_check_mark:
kbuildsycoca5 running…
kf.service.sycoca: Service type not found: “application/org.kiwix.desktop.x-zim”

I think my Plasma is pretty nice now - but it takes more than just nuking the old .config folder… The whole process took me maybe a half hour in total.

There’s a lot more to Dolphin than dolphinrc…

Basically, I opened Dolphin, then created a folder ~/home/ben/BakP5 and went dual pane F3

Then select all, deselect BakP5, and do ShiftF6 and log out/in again to a fresh desktop.

From there, it’s up to you to very selectively move your files back - frequently logging out again to load up and test.

Apart from the obvious things (and not all is obvious, I found that my ‘easystroke’ software was messing up some Plasma 6 stuff - now I am very limited in my gesture use, and have to refresh kwin every time…) just go with the ‘Half-Split’ technique…

Move half what you see, if it generates a bug, move half of that back… and so on.

Dolphin is behaving very nicely here… though I noticed that if Firefox doesn’t have the titlebar, the window causes the panel to ‘dodge’ from a very long way away… hence I now put the panel in one half of the screen and Firefox in the other…

I think I misunderstood the Dolphin part. OP is talking about desktop probably.

Anyhow… create a new user and test with that.

1 Like

Hah, didnt catch that. Thanks.
Of course the 5 variant is no longer the tool for kde 6 :sweat_smile:

and this is another problem with plasma 6:

i cant change the volume from there

I don’t think this is a Plasma 6 issue. My volume and audio work fine…

Start with a TEST user - see if it’s good.

Alternatively, just copy the entire contents (include hidden) of ~/home/ardv into a new folder ~/home/ardv/Plasma5

Then log out and log in, and try it again.

Just moving the .config folder is likely not clean enough (it wasn’t for me, anyway) nor is including the .local folder… it’s just simpler to move the whole shebang first.

When moving back, maybe leave the .cache folder behind to nuke later :wink:

i’ve added a new user and tested with it: the same result with the folder selecting and the volume problem. i still can change the volume from the keyboard shortcuts.

Then maybe something else deeper like unsupported packages?
Cant really say what/which except to just ‘look’.

1 Like

On thought I had, is that this may be related to a theme you’re using? It’s worth trying changing everything to the default Breeze theme and see how it goes.

I’m using breez dark theme
i tried back to breez white theme but the same problem occurs