No Available Connections Manjaro 5.10.42

Hi, I’m completely new on Manjaro KDE.

I have a problem with network connections when first time replacing my macOS (MacBook Air Early 2015) with Manjaro 21.0.7.

When I go to the network settings, it shows nothing (No available connections). I tried to reboot tge laptop, but still not working. I’m really confused right now, I couldn’t connect to the internet.

Some commands I have tested:

  • mhwd: it only shows video-linux, video-modesetting, and video-vesa. Nothing related to wifi

  • inxi -n: Broadcom BCM4360 802.11ac

  • rfkill list:
    0: hci0: Bluetooth
    Soft Blocked: no
    Hard Blocked: no

  • sudo pacman -S linux510-headers:
    error: target not found: linux510-headers

Can anyone solve this problem? Thanks!

This forum features a search function, don’t be afraid to use it.
Searching for Broadcom BCM4360 had some hits, these look promising:

This command result in error: script failed!
database file for ‘core’, ‘extra’, ‘community’, and ‘multilib’ does not exist.

This command also didn’t work for me, resulting in:
error: target not found: broadcom-wl

Fully update your system beforehand:

$ sudo pacman -Syu

edit: you need to connect to the internet by some other means (tethering a mobile device or use ethernet connection).

It returns:

error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize all databases

I’ve also tried to remove /var/lib/pacman/db.lck, but still not working

Hmm, are you sure?

$ ls -l /var/lib/pacman/

Do you have any network connectivity? The thing with these type of things is that you need some other network connection to solve your main network connection.


this result in:

total 0
drwxr-xr-x 1 root root 260 Jul 21 08:18 local
drwxr-xr-x 1 root root 60 Jul 21 08:18 sync

I don’t have any ethernet connection, only wifi.

My mobile tethering won’t show up on the network connections.

If your WiFi chip has no available driver, you can’t connect to any WiFi network.

In order to install the driver, it must first be downloaded, so you must have some kind of internet connectivity to receive the files.

okay then, thanks for your info

If you have mobile, you could use USB tethering. Unfortunately, I have never done it, so I can only give search suggestions.

I’ve tried it and it works well :slight_smile:

Hii @freggel.doe , sorry for my stupidity hehe. I’ve tried sudo pacman -Syyu using the USB tethering, and it works :slight_smile:

Thanks for helping!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.