No Audio working for Macbook (2017)

I have installed manjaro on both of my macbooks. One is Macbook10,1 (2017), and the other MacbookPro14,2 (2017), and I have tried one with KDE and one with Gnome.

The installation worked for both, but the audio is not working. I have enabled audio in both settings and alsamixer. I have also tried restarting and reinstalling pulseaudio.

I am sorry for not providing more info, but I am quite a noob, but I will happily supply more information if needed. I really have tried searching on google and the forum, but to no avail.

I have edited the file /etc/modprobe.d/alsa-base.conf, from “mb101” to “intel-mac-auto”

options snd-hda-intel model=intel-mac-auto

The bluetooth also is not working, but this is not as big of a dealbreaker, but if anyone have tips on bluetooth, those would also be taken with open arms. Here the problem seems to be that I cant activate bluetooth at all.

64 posts were split to a new topic: Macbook 14 audio


Follow the discussion here

and see if that helps.
If not, mention here where you got stuck so someone will assist you.

I managed to get the sound working on my Macbook 2017 10,1
To do so first upgrade the Kernel. The one I am running on at the moment is: 5.17.1-1-rt16-MANJARO

It is a realtime Kernel.
Then I ran the install script from

Did a reboot and it was working on the latest Manjaro at the time of this writing 21.2.6 Gnome edition

Thought I would leave this here in case anyone like me is still looking for it :slight_smile: