No audio output (tried many things)

So i have a desktop with a GA-Z77X-UD5H motherboard.
It already worked on the Case jack but currently neither that one works, only the nvidia output works(from the monitor’s jack).

I have already tried many things but still cant make it work.(my work around its to plug the headphones jack to the monitor and listen through the nvidia sound).

Also, i have a headphone amplifier (JDS LABS Atom) connected with jack 3.5mm and DT1990PRO headphones, i hope this helps.

inxi -Fazy :

  Kernel: 5.18.3-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=3e2c1024-e2c2-452e-b344-cfaf470bf600 rw quiet
    snd_hda_intel.dmic_detect=0 splash apparmor=1 security=apparmor
  Desktop: GNOME v: 42.2 tk: GTK v: 3.24.34 wm: gnome-shell dm: 1: GDM
    v: 42.0 2: LightDM v: 1.30.0 note: stopped Distro: Manjaro Linux
    base: Arch Linux
  Type: Desktop System: Gigabyte product: N/A v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Gigabyte model: Z77X-UD5H serial: <superuser required>
    UEFI: American Megatrends v: F16j date: 11/14/2017
  Info: model: Intel Core i7-3770K bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 built: 2012-15 process: Intel 22nm family: 6 model-id: 0x3A (58)
    stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2603 high: 3635 min/max: 1600/4400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2930 2: 3364 3: 3635
    4: 2442 5: 1674 6: 2422 7: 2124 8: 2239 bogomips: 56081
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Micro-Star MSI
    driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Turing process: TSMC 12nm
    built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 4 link-max: lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:2182 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: X: loaded: nvidia gpu: nvidia display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.00x11.26")
    s-diag: 1055mm (41.55")
  Monitor-1: DP-2 pos: primary,right res: 1920x1080 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: DP-4 pos: primary,left res: 1920x1080 dpi: 94
    size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.48.07 direct render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 3-4:3 chip-ID: 0951:170f
    bus-ID: 00:1b.0 class-ID: 0300 chip-ID: 8086:1e20 class-ID: 0403
  Device-2: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
  Device-3: Kingston HyperX SoloCast type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.18.3-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Intel 82579V Gigabit Network vendor: Gigabyte driver: e1000e
    v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: Gigabyte
    driver: atl1c v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: b000
    bus-ID: 06:00.0 chip-ID: 1969:1083 class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
  Local Storage: total: 2.04 TiB used: 513.67 GiB (24.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: TR200 size: 223.57 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 12.4 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD10EZEX-60WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
    used: 404.96 GiB (44.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 59 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 260 Uptime: 15m wakeups: 0 Memory: 15.57 GiB
  used: 2.84 GiB (18.2%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 1392
  pacman: 1388 lib: 398 flatpak: 0 snap: 4 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.17

sudo dmesg | egrep ‘(snd|sound|sof)’ :

[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64 root=UUID=3e2c1024-e2c2-452e-b344-cfaf470bf600 rw quiet snd_hda_intel.dmic_detect=0 splash apparmor=1 security=apparmor udev.log_priority=3
[    0.037211] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64 root=UUID=3e2c1024-e2c2-452e-b344-cfaf470bf600 rw quiet snd_hda_intel.dmic_detect=0 splash apparmor=1 security=apparmor udev.log_priority=3
[    0.179018] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.179019] software IO TLB: mapped [mem 0x00000000cb583000-0x00000000cf583000] (64MB)
[    0.668675] ata1.00: Features: Trust Dev-Sleep NCQ-sndrcv
[    3.084259] snd_hda_intel 0000:00:1b.0: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
[    3.084277] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)
[    3.084809] snd_hda_intel 0000:01:00.1: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
[    3.084821] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[    3.084865] snd_hda_intel 0000:01:00.1: Disabling MSI
[    3.084870] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    3.209853] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input12
[    3.209899] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input13
[    3.209941] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
[    3.209981] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input15
[    3.210020] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input16
[    3.210064] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input17
[    3.210105] input: HDA NVidia HDMI/DP,pcm=12 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input18
[    3.311512] snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC898: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[    3.311518] snd_hda_codec_realtek hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.311520] snd_hda_codec_realtek hdaudioC0D2:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    3.311523] snd_hda_codec_realtek hdaudioC0D2:    mono: mono_out=0x0
[    3.311524] snd_hda_codec_realtek hdaudioC0D2:    dig-out=0x11/0x1e
[    3.311526] snd_hda_codec_realtek hdaudioC0D2:    inputs:
[    3.311527] snd_hda_codec_realtek hdaudioC0D2:      Front Mic=0x19
[    3.311529] snd_hda_codec_realtek hdaudioC0D2:      Rear Mic=0x18
[    3.311531] snd_hda_codec_realtek hdaudioC0D2:      Line=0x1a
[    3.365283] input: HDA Intel PCH Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input19
[    3.367411] input: HDA Intel PCH Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input20
[    3.367456] input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input21
[    3.367498] input: HDA Intel PCH Line Out Front as /devices/pci0000:00/0000:00:1b.0/sound/card0/input22
[    3.367545] input: HDA Intel PCH Line Out Surround as /devices/pci0000:00/0000:00:1b.0/sound/card0/input23
[    3.367703] input: HDA Intel PCH Line Out CLFE as /devices/pci0000:00/0000:00:1b.0/sound/card0/input24
[    3.367744] input: HDA Intel PCH Line Out Side as /devices/pci0000:00/0000:00:1b.0/sound/card0/input25
[    3.367782] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input26
[    3.408314] usbcore: registered new interface driver snd-usb-audio

systemctl --user status pipewire

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor p>
     Active: active (running) since Mon 2022-06-13 01:51:30 WEST; 7min ago
TriggeredBy: ● pipewire.socket
   Main PID: 1154 (pipewire)
      Tasks: 2 (limit: 19101)
     Memory: 5.8M
        CPU: 811ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewi>
             └─1154 /usr/bin/pipewire

Jun 13 01:51:30 stoic-manj systemd[1037]: Started PipeWire Multimedia Service.

and finally alsa-info :

Hello @devRandom and welcome :wink:

Soo, you tried “many things”. When I read the terminal outputs, then everything seems to be totally normal.

Stupid question, but did you try to switch the sound card?

Settings → Sound



It show the line out with “sound” but i can’t hear anything.

When i say i have tried many things i mean uninstalling pipewire and run only pulseaudio, unmute on alsa and disable mic detect on the snd driver for example.

do you have installed sof firmware:
pamac install sof-firmware
reboot and check audio

Yes, I have :

Perfect :+1: That makes it so much easier…

So searching the web about this, I would say the pins are not allocated correctly for some reason.

Here is nice guide, how it can be done: Analog surround sound setup on Linux with a Realtek ALC898 sound card on the Clevo P751DM2-G · GitHub

It is not Manjaro specific, but the same software is used and targets the same chipset: ALC898. The key there is using hdajackretask (pkg: alsa-tools) to remap/override the pins and patch them when loading drivers.

However, here are also known pin fixes of specific models: HD-Audio Codec-Specific Models — The Linux Kernel documentation

So you can load a model like this:

sudo rmmod -v snd_hda_intel
sudo modprobe -v snd_hda_intel model=gpio1

So i have been working around with that tool and so far I didn’t manage to get sound (hdajackretask), but:
on gnome settings only shows the SPDIF output not the lineouts that i tried to remap, and in the tool qpwgraph i can manage to have temporary sound on the line outs but everytime i open the gnome settings it removes that sound…

After reading this: i found out that some people could get sound on the grey jack.So I used the hdajackretask tool to remap the grey socket to headphones and Worked so far.

I really wanted to thank you for your help!
keep doing your good work. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.