No audio on Nomachine only in Manjaro

I have 3 PC with Manjaro 20.03 installed and none of them gets audio output from NoMachine. The 3 of are quite different as one is a workstation (ryzen 3950x, 32g, Dual Nvidia rtx2070 & 1660), one is a htpc (Intel i3-4330, 16g), and Asus laptop(Intel i5-10510, 32g, Nvidia mx210).
The sound doesn’t work from any NoMachine server (VM or physical) even between Manjaro servers.

Any idea?

can you provide

inxi -Fxza --no-host

Have you a dummy output and sometimes after restart you have audio , sometimes not?
Many have problems the last days with audio with pc’s with snd-hda_-intel !
Solution:
Open /etc/modprobe.d/alsa-base.conf and add the following line at the end:

options snd-hda-intel dmic_detect=0

Then:

pulseaudio -k && sudo alsa force-reload

You will heard the sound.

I don’t have this file or it is empty.

inxi -Fxza --no-host
System:    Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=360d75d8-3fc2-4fdd-a0aa-1dff664b34a5 rw quiet 
           udev.log_priority=3 "amd_iommu=on rd.driver.pre=vfio-pci kvm.ignore_msrs=1" 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7B93 v: 1.0 serial: <filter> 
           Mobo: Micro-Star model: MPG X570 GAMING PRO CARBON WIFI (MS-7B93) v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: 1.70 date: 07/14/2020 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mobile Mouse MX Anywhere 2 serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 16-Core (2-Die) model: AMD Ryzen 9 3950X bits: 64 type: MT MCP MCM arch: Zen 2 family: 17 (23) 
           model-id: 71 (113) stepping: N/A microcode: 8701021 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 224096 
           Speed: 2599 MHz min/max: 2200/3500 MHz boost: enabled Core speeds (MHz): 1: 3198 2: 2006 3: 2207 4: 2203 5: 2206 
           6: 2203 7: 2198 8: 2199 9: 3324 10: 2044 11: 1984 12: 1956 13: 2040 14: 2199 15: 2197 16: 2199 17: 2200 18: 2199 
           19: 2196 20: 2195 21: 2199 22: 2200 23: 2200 24: 1955 25: 2200 26: 2198 27: 2198 28: 2202 29: 2202 30: 2199 
           31: 2232 32: 2205 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU116 [GeForce GTX 1660] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 24:00.0 
           chip ID: 10de:2184 
           Device-2: NVIDIA TU106 [GeForce RTX 2070 Rev. A] vendor: Micro-Star MSI driver: vfio-pci v: 0.2 alternate: nouveau 
           bus ID: 2d:00.0 chip ID: 10de:1f07 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting,nouveau alternate: fbdev,nv,vesa 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3360x1080 s-dpi: 96 s-size: 889x285mm (35.0x11.2") s-diag: 934mm (36.8") 
           Monitor-1: DP-1 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") diag: 584mm (23") 
           Monitor-2: HDMI-1 res: 1440x900 hz: 60 dpi: 90 size: 408x255mm (16.1x10.0") diag: 481mm (18.9") 
           OpenGL: renderer: llvmpipe (LLVM 10.0.1 256 bits) v: 3.3 Mesa 20.1.5 compat-v: 3.1 direct render: Yes 
Audio:     Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 24:00.1 
           chip ID: 10de:1aeb 
           Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI driver: vfio-pci v: 0.2 
           alternate: snd_hda_intel bus ID: 2d:00.1 chip ID: 10de:10f9 
           Device-3: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 2f:00.4 chip ID: 1022:1487 
           Device-4: Frys EDIFIER R19U type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-1:2 chip ID: 0001:0201 
           serial: <filter> 
           Device-5: C-Media Audio Adapter (Unitek Y-247A) type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1.1:3 
           chip ID: 0d8c:0014 
           Sound Server: ALSA v: k5.8.1-3-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb v: 5.6.0-k port: c000 bus ID: 26:00.0 
           chip ID: 8086:1539 
           IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: c000 bus ID: 28:00.0 chip ID: 8086:2723 
           IF: wlo1 state: down mac: <filter> 
           IF-ID-1: br1 state: up speed: 1000 Mbps duplex: unknown mac: <filter> 
           IF-ID-2: docker0 state: down mac: <filter> 
           IF-ID-3: virbr0 state: down mac: <filter> 
           IF-ID-4: virbr0-nic state: down mac: <filter> 
           IF-ID-5: ztrtaql45w state: unknown speed: 10 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 5.69 TiB used: 3.76 TiB (66.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXM7 scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 960 EVO 250GB size: 232.89 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 3B7QCXE7 scheme: GPT 
           ID-3: /dev/nvme2n1 vendor: Micron model: 2200S NVMe 256GB size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 22001040 
           ID-4: /dev/sda vendor: Seagate model: ST2000DM001-9YN164 size: 1.82 TiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC4C scheme: GPT 
           ID-5: /dev/sdb vendor: Western Digital model: WD4003FZEX-00Z4SA0 size: 3.64 TiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: AC50 scheme: GPT 
Partition: ID-1: / raw size: 232.59 GiB size: 227.94 GiB (98.00%) used: 60.93 GiB (26.7%) fs: ext4 dev: /dev/nvme1n1p2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A gpu: nouveau temp: 43 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 925 
Info:      Processes: 479 Uptime: 14m Memory: 31.35 GiB used: 2.05 GiB (6.5%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Packages: pacman: 1206 lib: 330 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

I’ve edited your inxi output for better readability :slight_smile:

You must create it
Then in terminal:systemctl --user restart pulseaudio

I apologized for my stupidity but, create what? How?
EDIT:
ok I’ve created the file and made the command in terminal but it doesn’t work and now I have no sound at all. I lost all my sounds devices.

Change content of /etc/modprobe.d/alsa-base.conf to:

options snd-hda-intel model=generic

In Your home directory : rename ./config/pulse in ./config/pulse.old

Reboot your computer and adjust your settings in pavucontrol

These settings makes my computer unresponsive and freeze as soon as I touch the sound icon.

I also have the same problem… Everything worked on an older version of the kernel, but not since the upgrade of August 5th.
Please tell me if you find a solution!
By the way, I also installed fedora 32 on a different partition and everything works perfectly out of the box.

You have 5 audio devices !! Manjaro seems to have problems with multiple audio devices.I think we’ve got to wait until there is an update from Manjaro for this sound bug.
Delete the .config/pulse/ folder again ; some people say to change content in alsa-base.conf to:
options snd-hda-intel model=auto . Then in terminal : systemctl --user restart pulseaudio

I don’t know if that will work.
If it doesn’ work always try to restart pulseaudio again; sometimes you have sound and sometimes you don’t. It seems there isn’t really a solution yet to have permanently sound

As I said I have 3 pc with Manjaro and nomachine installed. All with very different configuration and none of them have audio coming from nomachine. I also installed Manjaro at work and no sound from nomachine either. I previously had Kubuntu, Pop_os, Mint, OpenSuse and Fedora installed on the same machine and they were all working fine. I love Manjaro but Nomachine is essential for me for my work so if I can’t get the sound working or find a work around I’m afraid I will have to find another distro.