No audio in Manjaro i3

audio
i3

#1

I’m trying to get the audio from the tv, that is connected via HDMI cable.

aplay -l

card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC1220 Analog [ALC1220 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 1: ALC1220 Digital [ALC1220 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aplay -L

null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
pulse
    PulseAudio Sound Server
hdmi:CARD=Generic,DEV=0
    HD-Audio Generic, HDMI 0
    HDMI Audio Output
hdmi:CARD=Generic,DEV=1
    HD-Audio Generic, HDMI 1
    HDMI Audio Output
hdmi:CARD=Generic,DEV=2
    HD-Audio Generic, HDMI 2
    HDMI Audio Output
hdmi:CARD=Generic,DEV=3
    HD-Audio Generic, HDMI 3
    HDMI Audio Output
usbstream:CARD=Generic
    HD-Audio Generic
    USB Stream Output
sysdefault:CARD=Generic_1
    HD-Audio Generic, ALC1220 Analog
    Default Audio Device
front:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC1220 Analog
    Front speakers
surround21:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC1220 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC1220 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC1220 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC1220 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC1220 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC1220 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Generic_1,DEV=0
    HD-Audio Generic, ALC1220 Digital
    IEC958 (S/PDIF) Digital Audio Output
usbstream:CARD=Generic_1
    HD-Audio Generic
    USB Stream Output

I’ve created a ~/.asoundrc file but it’s clearly wrong, because I can move volume up and down now, but there’s still no sound. I can keep filling that file with random device number, but id like to have some help.
Thx


#2

Is the HDMI device the active device?
Maybe use pavucontrol to check.


#3

when I run pavucontrol I get “connecting to pulseaudio…” popup window forever.
I’ve tried to run install_pulse script then reboot but nothing is working.


#4

I haven’t installed i3 in years, maybe it doesn’t come with pulseaudio, or does it? Someone who’s more up to date can certainly shed some light.


#5

no, indeed there’s no pulseaudio by default.
But there a script “install_pulse” that, when launched, will install pulse and all its depencies.


#6

If you right click on the sound icon then 1 and then 2 and change from default to the HDMI, does it change something?

image


#7

I have 2 generic something with the same name under default, the first one has 4 volume controls that cannot be moved from 0, the second have a lot of volume controls, none of the playback ones is muted, but when I try to open a youtube video I get an HTML 5 error and the video cannot be reproduced.


#8

And if you Open Mixer (same as opening alsamixer from terminal) and you press F6 to select the card, does the HDMI one shows in that list? If you select it, can you turn up the sound ?


#9

Yes I could turn the volume up, for 1 of the 2 HDMI entries shown when pressing F6, but at the point there was no sound really(tested by trying and play a web radio) plus YT videos began to show an html 5 error.
After several installations of the OS I decided to attach a set o speakers directly to the case, instead of tryng to get the audio from the TV attached via HDMI cable, because:

  1. I’m too noob to troubleshoot alsa.
  2. There are webpages (google) from 2018 that state that my AMD apu (ryzen 2400g) have problems with HDMI audio in linux.
  3. I do not know if it is the case anymore.

The day I’ll be in the mood to reinstall the OS again, experimenting with speakers, I’ll let you know.

Thanks.