After removing home config file Lightdm loops Problem

I removed a lot of directors from home i thought those are useless . now i am facing loop problem.
I tried by reinstalling lightdm + xorg didn’t worked. Sudo pacman -Rcns lightdm xorg
sudo pacman -S lightdm xorg.

In your filesystem root is a two files

  • rootfs-pkgs.txt
  • desktopfs-pkgs.txt

You can use those to reinstall the system.

First strip the package names to file

cat /desktopfs-pkgs.txt | awk '{print $1;}' > ~/pkglist.txt

Then use the new file as input for pacman

sudo pacman -Syu --needed - < ~/pkglist.txt

I just spotted the word home - copy all of the files - including the hidden ones - from /etc/skel to your home.

cp -r /etc/skel/.* ~

This latter approach would fix if the loop is related to your removal of xorg related files.

1 Like

Would probably be a good time to also:

  1. Ask yourself: Why am I deleting things without a backup/knowing what they actually are or do?

  2. Again, ask yourself: Why am I running the pacman command to cascade-remove packages?

Well i removed some directory inside ~/ i was trying to understand why all of this dot file mess around
I dont think i removed

sudo pacman -Syu - < /desktopfs-pkgs.txt

It gave me thousands of missing package
error: terget not found: and_that_package_name

cp -r /etc/skel/.* ~ and this /etc/skel/ is a empty directory…

I have backup … I dont want to restore… i think my timeshift have error if i try to restore… it says go to live system and then restore …
trying to solve this problem manually.also where is the gtk theme icons goes? Like :- candy icon?
is it on only /usr/share?
Is there any other directory for config?

My bad - I forgot the versions - strip the pkgnames to a file and use the file

First strip the package names to file

cat /desktopfs-pkgs.txt | awk '{print $1;}' > ~/pkglist.txt

Then use the new file as input for pacman

sudo pacman -Syu --needed - < ~/pkglist.txt

And /etc/skel is not empty - as said all files including the hidden ones - try

ls -a /etc/skel 

and you will see it is not - that is - unless you deleted that too.

If you have been a spree - you best option is to restore from backup or reinstall.

1 Like

I just started my computer and i didn’t did anything but it runs

Only cp -r /etc/skel/.* ~ line is enough thanks a lot for your support :heart:

Inside of /etc/skel/
How it can solve the issue?
tree -a ξ‚² :heavy_check_mark:
β”œβ”€β”€ .bash_logout
β”œβ”€β”€ .bash_profile
β”œβ”€β”€ .bashrc
β”œβ”€β”€ .config
β”‚ β”œβ”€β”€ autostart
β”‚ β”‚ └── manjaro-hello.desktop
β”‚ β”œβ”€β”€ falkon
β”‚ β”‚ └── profiles
β”‚ β”‚ β”œβ”€β”€ manjaro
β”‚ β”‚ β”‚ β”œβ”€β”€ bookmarks.json
β”‚ β”‚ β”‚ β”œβ”€β”€ browsedata.db
β”‚ β”‚ β”‚ └── version
β”‚ β”‚ └── profiles.ini
β”‚ └── ranger
β”‚ β”œβ”€β”€
β”‚ β”œβ”€β”€
β”‚ β”œβ”€β”€ plugins
β”‚ β”‚ └──
β”‚ β”œβ”€β”€ rc.conf
β”‚ └──
└── .zshrc