No Audio from Rog Strix scar 18 Laptop

Hi Team

Long time user, Recently got the Rog strix Scar 18 laptop , primarily to use for Machine learning. So far everything is working smooth. Except the audio… so far haven’t managed to get it to work.

Happy to provide details as necessary , :slight_smile:

Thanks in Advance

Hi there. Hopefully you get this sorted soon. What DE are you using? Also, Pipewire, PulseAudio? The more info the better. Also, are you using 6.1 LTS kernel & what results do you get if you try 5.15? All the best with this one…

This laptop is damn new, even the soundcard is from 2022, so also use as new kernel as possible, either 6.1 or 6.2. Forget anything earlier, usually new hardware support is not backported even to the previous LTS. It’s still not a guarantee, though. Getting day-1 support on a complex machine does not typically happen. My GL503VD got its full support after 1.5 year or so from the date I bought, and that still excluded the RGB control (that one came in 2021, I think).

Thanks for your response. I’m currently using GNOME as my DE. Regarding the audio system, I am using PipeWire. I apologize for not mentioning these details earlier.

As for the kernel, I’m using the 6.2.10-1-MANJARO kernel. I haven’t tried the 5.15 kernel yet, but I can give it a shot and let you know how it goes.

Additionally, here’s the output of inxi -A:

Device-1: Intel driver: snd_hda_intel
Device-2: NVIDIA driver: snd_hda_intel
API: ALSA v: k6.2.10-1-MANJARO status: kernel-api
Server-1: PipeWire v: 0.3.68 status: active

I hope this information helps you in assisting me with this issue. Thanks again for your help!

1 Like

can you report

inxi -Fza

Here’s the output of inxi -Fza :

  Kernel: 6.2.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.2-x86_64
    root=UUID=182723df-af4e-4300-8fae-1c8a8b56edd6 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 43.4 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ROG Strix G834JZ_G834JZ v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: G834JZ v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: G834JZ.308 date: 03/17/2023
  ID-1: BAT0 charge: 90.5 Wh (100.0%) condition: 90.5/90.0 Wh (100.5%)
    volts: 17.5 min: 16.0 model: AS3GYFG3KC R220358 type: Unknown
    serial: <filter> status: full
  Info: model: 13th Gen Intel Core i9-13980HX bits: 64 type: MST AMCP
    arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
    process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
    microcode: 0x112
  Topology: cpus: 1x cores: 24 mt: 8 tpc: 2 st: 16 threads: 32 smt: enabled
    cache: L1: 2.1 MiB desc: d-16x32 KiB, 8x48 KiB; i-8x32 KiB, 16x64 KiB
    L2: 32 MiB desc: 8x2 MiB, 4x4 MiB L3: 36 MiB desc: 1x36 MiB
  Speed (MHz): avg: 1936 high: 2400 min/max: 800/5400:5600:4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 987 2: 2400 3: 950 4: 800
    5: 871 6: 2400 7: 2400 8: 2400 9: 999 10: 2400 11: 938 12: 2400 13: 800
    14: 2400 15: 960 16: 898 17: 955 18: 2400 19: 2400 20: 2400 21: 2400
    22: 2400 23: 2400 24: 2400 25: 2400 26: 2400 27: 2400 28: 2400 29: 2400
    30: 2400 31: 2400 32: 2400 bogomips: 154880
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Raptor Lake-S UHD Graphics vendor: ASUSTeK driver: i915
    v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+ ports:
    active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 0000:00:02.0
    chip-ID: 8086:a788 class-ID: 0300
  Device-2: NVIDIA AD104M [GeForce RTX 4080 Max-Q / Mobile] vendor: ASUSTeK
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022-23+ bus-ID: 0000:01:00.0
    chip-ID: 10de:27e0 class-ID: 0300
  Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 2-8:3 chip-ID: 322e:2122 class-ID: 0e02
  Display: x11 server: X org v: with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: nouveau alternate: fbdev,nv,vesa dri: iris gpu: i915
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 model: BOE Display NE180WUM-NY1 built: 2022
    res: 1920x1200 hz: 165 dpi: 126 gamma: 1.2 size: 388x242mm (15.28x9.53")
    diag: 457mm (18") ratio: 16:10 modes: 1920x1200
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel Graphics (RPL-S)
    direct-render: Yes
  Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:7a50
    class-ID: 0403
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:22bc class-ID: 0403
  API: ALSA v: k6.2.10-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.68 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 0000:00:14.3
    chip-ID: 8086:7a70 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    port: 4000 bus-ID: 0000:6c:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp108s0 state: down mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 2-14:4
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
    driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f rev:
    class-ID: 0104
  Local Storage: total: 2.79 TiB used: 60.23 GiB (2.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Samsung
    model: MZVL21T0HCLR-00B00 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: GXA7601Q temp: 44.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Seagate
    model: XPG GAMMIX S70 BLADE size: 1.86 TiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 3.2.F.66 temp: 56.9 C scheme: GPT
  ID-1: / raw-size: 343.64 GiB size: 337.18 GiB (98.12%)
    used: 60.17 GiB (17.8%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:10
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 66.9 MiB (26.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:4
  Alert: No swap data was found.
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2100
  Processes: 510 Uptime: 3h 20m wakeups: 2 Memory: 62.42 GiB
  used: 4.39 GiB (7.0%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 alt: 11 clang: 15.0.7 Packages: 1329
  pm: pacman pkgs: 1319 libs: 328 tools: gnome-software,pamac,yay pm: flatpak
  pkgs: 10 Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.26

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

check with alsamixer is there is mute ( MM )

nope not on Mute…!!!

Turned off via keyboard? (CTRL + F??)

Not on Mute… and yeah checked with keyboard too

maybe this helps ?

You my friend are a genius… I have audio… but its like 20% volume… as in sounds low… tried adjusting volume… but can’t increase for some reason…any suggestions?