No app sound (though system sound) in XFCE in VMware


I just installed Manjaro as a guest machine to VMware Workstation. I get system sound (e.g. the beep when you click the Manjaro power icon at bottom right) but no application sound (e.g. from VLC or Youtube on Firefox). How could I get application sound?

I am new to Manjaro and fairly new to Linux itself, and so don’t know what is relevant information. I will just list all the steps I took so far because they are not many. I’d be happy to provide any additional information necessary to solve the issue. Thank you very much.

Steps so far

  1. Install manjaro-xfce-22.1.0-230421-linux61.iso as guest to VMware Workstation 17.0.2 pro running on Windows 11 pro.
  2. When the VM boots, notice the message: “The default sound device cannot be opened: A device ID has been used that is out of range for your system. Failed to connect virtual device sound.”
  3. Update Manjaro using sudo pacman -Syu (plus some preliminary commands for updating the mirror).
  4. Create and enable vmwaretools.service (so that open-vm-tools package would start with Manjaro).
  5. Start Manjaro > click speaker icon > Audio mixer… > see a popup named “Volume Control” > Configuration (tab) > Change Profile from “Analog Stereo Duplex” to “Analog Stereo Output”.
  6. Restart Manjaro > see no more the message “The default sound device cannot be opened…”.
  7. Start an app that plays sound (e.g. VLC, Firefox).
  8. Open “Volume Control” window > Output Devices (tab).
  9. See “ES1371/ES1371/ Creative Labs CT2518 (Audio PCI 64V/128/5200 / Creative CT4810/CT5803.CT5806 [Sound Blaster PCI]) Analog Stereo” is not muted.
  10. See also two bar graphs. The top one is fixed at 94%. The bottom one moves (grows and shrinks) with what would appear to be the volume of the video being played (in VLC or Firefox).
  11. For background, I might add that both the physical (Windows 11) machine and another VMware guest (Windows 11) machine give me sound just fine.
  12. Also for background, I get system sound (e.g. beep on clicking Manjaro power button) no matter which value I set Profile (in Volume Control’s Configuration tab) to, the available values being “Analog Stereo Duplex”, “Analog Stereo output”, “Analog Stereo Input”, or “Off.”

Sorry, but what I called “system sound” may not be that at all. In fact, the only sound I ever heard from this Manjaro VM is the one from clicking the power button. That beep’s volume remains constant even when I change the “System Sounds” volume in Volume Control’s Playback tab.


Maybe try another sound controller in vmware? Usually it works with ich9 in libvirt/virt-manager/gnome-boxes or Intel HD Audio in virtualbox. I don’t use vmware, so I don’t know what options you have there.

I feel very silly to reply to my own post, but am recording the solution I found for anybody that might run into the same thing.

The problem was in VMware. I did:

  • Go to VMware’s Console View.
  • In “Devices”, double-click “Sound Card”.
  • See that “Connected” is unticked > tick it.

That was it.

I found it strange that “Connected” remained unticked even though “Connect at power on” was ticked.

Anyway, after manually ticking the item as above, it stayed ticked through several restarts.


I want to add that I also had to do step 5 of the original post, namely changing Profile from “Analog Stereo Duplex” to “Analog Stereo Output”. When that was set to “Analog Stereo Duplex”, I found that I could not tick “Connected.” Ticking it and trying to close that window gave me again the “The default sound device cannot be opened” warning.

To summarize, if you run into this issue, you have to change the Profile to “Analog Stereo Output” and tick “Connected”.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.