No Advanced Audio Sink for Bluetooth Headset?

This might be a big vague right now since I don’t have a picture of the effect, but If I pair my BT headset and then go to system settings -> audio, the type of communications module the headest is using is the one that’s not good. (It’s not the advanced audio (codec?)) which gives almost crystal clear audio, and is instead the one where the audio has a lot of static and distortions in it.

Why aren’t there other options aside for the bad one? (I’ll get pictures later)

Hey, @Sarah

Don’t know the answer to your issue, but since this is not related to Hardware from partners provided with Manjaro preinstalled, i will move the topic from #support:manjaro-hardware to #support:sound

Someone might assist you with this.

To be able to use my bluetooth headphones with lossless transfer codecs I needed to install the packages: pulseaudio-modules-bt and libldac (for LDAC support) as well. After installation of these two packages, a reboot an repairing my headphones I was able to switch between different codecs in the Settings when I selected my headphones as output device!

https://aur.archlinux.org/packages/pulseaudio-bluetooth-a2dp-gdm-fix

Installing this fixed the issue for me.

I applied this fix by itself, but it didn’t take :smiley:. The headset disappears from the audio list on pairing now.

Kind of strange that there are 2 packages that appear to do the same thing.

I installed this one, and things (should have) worked ok. A2DP is available and I can place it on the headset in the audio settings. The headset also appears in the BT list, but the exact moment I try to play audio over it, the headset disappears from the BT list in system settings/audio.

Not sure how to handle this.

I do not know what is wrong currently. The setup like I described worked like that until the last stable update a few days ago. After that update bluetooth is completely broken. Sometimes my headset does not connect, now when I select it as an output device sound still plays over external speakers.

I think this is a bug and not just a misconfiguration issue since I did not change anything. I however do not know where the correct place to report this is.

Ah, hopefully someone does then and can fix it soon :slight_smile:

The software stack for bluetooth in Linux is called BlueZ it seems and contact information can be found here: BlueZ » Contact. Unfortunately they do not seem to have a repository with a issue reporting function but a classical mailing list and IRC channels, which makes reporting this more effort.

Can you do me a favor and try out if you still have your issues when using Kernel LTS version 5.4?

I had the same issue, and was able to fix it by editing my bluetooth configuration file (/etc/bluetooth/main.conf):

Add the line (without quotes) “Disable=headset” to the end of main.conf.

After rebooting and connecting my bluetooth audio device, I was able to enable the A2DP profile.

I did not need to install any of pulseaudio-modules-bt, libldac, or pulseaudio-bluetooth-a2dp-gdm-fix to fix my issue. I am using KDE Plasma 5.19.4, kernel 5.8.0-2. My bluetooth adapter is from BlueZ (this package was installed by default for my distro).

Something strange happens when I do this:

A2DP appears and everything seems like it is going to work out well, but when I go to play audio, my headset disappears from the list of option and reverts back to the speakers.

The headset after this is no longer an option in any audio panel.

That worked for me (after 2 days troubleshooting…).
Thank you!

1 Like