Night Color Not Turning Off

Night Color feature is set to turn on/off at custom times. Recently, it will pass the cutoff time to disengage, but stays on until manually set to off.

I’m seeing these entries in the log:

Apr 28 09:00:00 local-user kwin_x11[3710]: kwin_nightcolor: Error in time calculation. Deactivating Night Color.
May 01 09:00:00 local-user kwin_x11[3775]: kwin_nightcolor: Error in time calculation. Deactivating Night Color.
May 16 09:00:00 local-user kwin_x11[3749]: kwin_nightcolor: Error in time calculation. Deactivating Night Color.

System Info:

Kernel: 5.15.109-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1 Desktop: KDE Plasma
v: 5.27.4 Distro: Manjaro Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-I GAMING v: Rev X.0x
serial: UEFI: American Megatrends v: 4005 date: 07/13/2021
Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+ rev: 0 cache:
L1: 512 KiB L2: 4 MiB L3: 32 MiB
Speed (MHz): avg: 3990 high: 4655 min/max: 2200/4850 boost: enabled cores: 1: 3385 2: 3432
3: 4164 4: 4001 5: 4277 6: 4655 7: 4637 8: 3415 9: 4508 10: 3417 11: 3318 12: 3991 13: 4381
14: 4140 15: 3852 16: 4280 bogomips: 121417
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Gigabyte driver: nvidia v: 530.41.03
arch: Turing bus-ID: 0a:00.0
Device-2: Logitech HD Webcam C510 driver: snd-usb-audio,uvcvideo type: USB bus-ID: 3-1:2
Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: nvidia gpu: nvidia resolution:
1: 2560x1440 2: 2560x1440 3: 2560x1440
API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
direct-render: Yes
Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 0a:00.1
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0c:00.4
Device-3: Logitech HD Webcam C510 driver: snd-usb-audio,uvcvideo type: USB bus-ID: 3-1:2
Device-4: Kingston HyperX Cloud Alpha S driver: hid-generic,snd-usb-audio,usbhid type: USB
bus-ID: 3-2:3
API: ALSA v: k5.15.109-1-MANJARO status: kernel-api
Server-1: JACK v: 1.9.22 status: off
Server-2: PipeWire v: 0.3.70 status: active
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 05:00.0
IF: wlp5s0 state: down mac:
Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel port: f000
bus-ID: 06:00.0
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac:
Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB bus-ID: 3-6:5
Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block:
hardware: no software: yes address: see --recommends
Device-1: md127 type: mdraid level: mirror status: active size: 1.82 TiB
Info: report: 2/2 UU blocks: 1953381376 chunk-size: N/A
Components: Online: 0: sda1 1: sdb1
Local Storage: total: raw: 9.21 TiB usable: 7.39 TiB used: 735.83 GiB (9.7%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB temp: 41.9 C
ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB temp: 32.9 C
ID-3: /dev/sda vendor: Crucial model: CT2000MX500SSD1 size: 1.82 TiB
ID-4: /dev/sdb vendor: Crucial model: CT2000MX500SSD1 size: 1.82 TiB
ID-5: /dev/sdc vendor: PNY model: CS900 120GB SSD size: 111.79 GiB
ID-6: /dev/sdd vendor: Western Digital model: WD40EZRX-00SPEB0 size: 3.64 TiB type: USB
ID-1: / size: 915.53 GiB used: 735.83 GiB (80.4%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
ID-1: swap-1 type: partition size: 111.79 GiB used: 0 KiB (0.0%) dev: /dev/sdc1
System Temperatures: cpu: 51.9 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 403 Uptime: 7h 15m Memory: available: 62.71 GiB used: 9.25 GiB (14.7%) Init: systemd
Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1767 Client: KDE Plasma v: 5.27.4 inxi: 3.3.27

I have noticed it being odd recently.

Out of curiosity … can you edit the custom time?
(that seems to have broken on a number of KDE systems I have seen)

Yes, I am still able to edit the custom times.

Interestingly, the problem is intermittent. Sometimes it turns on/off correctly, while at other times it does not change at the respective times.

1 Like

I’ve also been having this problem every several days, when the night color turns on successfully, and i let the screen turn itself off from inactivity during the night, and then reawaken it (well after the night color turn off point should have happened) the next day to recreate the problem.

Continuing to see night color fail to turn on/off at designated times. Manually toggling it on/off still works.

I don’t think there is really much of anything anyone here can do to fix it. Perhaps report it (it’s probably already reported) to

It does seem to work as intended on my desktop, so I cannot offer any other help. I did however choose Sunset and sunrise at manual location and entered the latitude and longitude coordinates.

1 Like

Great suggestion; I’ll poke around on their bug tracker and see what I can find out.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.