Night Color Doesn't Apply Changes

The new "Night Color" configuration option seems to not be working properly on my system. I have redshift installed and disabled it to try using Night Color, and it worked for a while, but now the Night Color module in System Settings won't accept any changes. I can change the various options, but the Apply button remains greyed out, meaning the options don't get applied. Additionally, I can't disable Night Color; if I uncheck the box for enabling it and close the window then go back into System Settings, Night Color is re-enabled again. Does anyone have an idea as to what could be causing this? I did a search on the KDE buglist but didn't find anything similar to this.

i have the same issue... if anyone find an answer please let me know :slight_smile:

It might be worth creating one then, it's a new feature so such teething issues will need addressing. I don't use night color or redshift any more since I already have all my displays calibrated to sRGB at 120 candela which is dark enough not to be excessively bright at night but still comfortably visible during the day too. There's also scientific research which debunks the blue light output of displays, it's more to do with how bright the screen is than the blue levels.

Hi, it's a known bug:

https://www.mail-archive.com/kde-bugs-dist@kde.org/msg392275.html

to fix temporary:


SUMMARY
Switching to "Times" operation mode breaks night color settings and you can't
save your new changes anymore or disable it. As a workaround you can remove the
[NightColor] section from ~/.config/kwinrc, restart kwin and you'll be able to
change settings normally again.

1 Like

Can someone post a link to how to perform this edit?
Thanks!

Open ~/.config/kwinrc with Kate.
Remove these lines, reboot.

Screenshot_20191203_050207

Forum kindly sponsored by