Nieuwe linux laptop met manjaro

Hallo beste mensen,
Aan iedereen een Voorspoedig en Gezond 2021.
Onlangs nieuwe Linux laptop gekocht en ik worstel weer met het numlock probleem,ik heb alle aanwijzingen gevolgd die mij zijn aangeboden door Aragorn.

Ziehier de aanwijzingen : Een aantal dingen die je kan doen…

1. Open het bestand /etc/sddm.conf en zorg ervoor dat NumLock daar ook wordt ingeschakeld. :arrow_down:
[General]
InputMethod=
Numlock=on
2. In System Settings , onder Hardware → Input Devices → Keyboard:arrow_down:

Hardware tab → NumLock on Plasma Startup

… en optioneel… :arrow_down:

Advanced tab → Compatibility Options →Numeric keypad always enters digits (as in macOS)

Spijtig genoeg geeft dat bij de nieuwe laptop geen oplossing.
Ik heb ook al gekeken in de Arch wiki maar kom er niet uit.
Graag hulp aub .

Ik gebruik Manjaro KDE nieuwste versie

Groeten,

Het enige wat ik op dit moment kan bedenken is dat je misschien een ander type toetsenbord moet selecteren.

System Settings → Hardware → Input Devices → Keyboard →Keyboard Model

:thinking:

P.S.: Als je NumLock ook in een tty automatisch wil inschakelen moet je systemd-numlockontty uit de AUR installeren… :arrow_down:

pamac build systemd-numlockontty
sudo systemctl enable --now systemd-numlockontty

Hallo Aragorn,
Klavier : stond origineel ingesteld op Generic 86-Key PC
en Belgian Default
Ik heb het aangepast op Belgian ISO Alt zoals op mijn oude Asus Laptop
Hier werkt het perfect in Manjaro KDE
Het rare is dat na een volledige herstart van de laptop mijn instelling verdwenen is,de instelling gaat terug naar de instelling van de leverancier ttz Generic 86 Key PC en Belgian Default ondanks dat ik mijn instelling bevestigd heb.Hoe kan dat ?

systemd-numlockontty heb ik geinstalleerd
waar moet ik Pamac build systemd-numlockontty ingeven
wat moet ik met sudo systemctl enable – now systemd-numlockontty
Geeft steeds foutmelding bv; Unknown command verb systemd-numlockontty

Alvast bedankt voor uw hulp .

Hi @rediser,

AFAIK the commands should be run in a terminal. I don’t know which one you use.

pamac build systemd-numlockontty

(Note the first character is not a capital.)

sudo systemctl enable – now systemd-numlockontty

(Note the sudo prefix for the last command.)

The error should, theoreticlly, go away is the installation of systemd-numlockontty was successful.

Hope this helps.

Hoe dat kan weet ik ook niet ─ het zou niet mogen gebeuren. Maar er zijn twee plaatsen waar je het toetsenbord kan configureren, en het is natuurlijk belangrijk dat die allebei congruent zijn.

  • De eerste plaats is in System Settings → Manjaro → Keyboard Settings. Deze instelling heeft betrekking op het hele systeem.

  • De tweede plaats is System Settings → Hardware → Input Devices → Keyboard. Deze instelling is enkel van toepassing binnen de gebruikersaccount waarmee je bent ingelogd.

Als je het al geïnstalleerd hebt, dan moet je het uiteraard niet meer manueel ingeven ─ dat was overigens een opdracht die je in een terminal moet ingeven.

Het tweede commando moet je ook in een terminal-venster ingeven, maar wel letterlijk zoals ik het heb gegeven. Eén verkeerd lettertje of koppelteken en het werkt niet ─ computers nemen alles letterlijk, weet je wel? :wink:

sudo systemctl enable --now systemd-numlockontty

[quote=“Mirdarthos, post:4, topic:47303”]

sudo systemctl enable – now systemd-numlockontty

[/quote]`
Na copy - paste van de opdrachtregel in de console krijg ik volgende foutmelding
~]$ sudo systemctl enable – now systemd-numlockontty
[sudo] wachtwoord voor desirejb:
Invalid unit name “–” escaped as “\xe2\x80\x93” (maybe you should use systemd-escape?).
Failed to enable unit: Unit file \xe2\x80\x93.service does not exist

Sorry maar dit werkt blijkbaar niet .

Het is maar een idee, heb je al eens in de BIOS gekeken of het mogelijk is de numlock aan te zetten bij het booten?

@rediser,

It looks to me as if that error is thrown because of the - in the command name. Try wrapping the service name in quotes:

sudo systemctl enable – now "systemd-numlockontty"

I’m not sure if what I think is correct or even if the solution is correct and will work. But I do know ir’s worth a shot.

looks like a typo / ziet er uit als een tikfout
should be / moet zijn

sudo systemctl enable --now systemd-numlockontty

1 Like

Thank you for catching that one!

@rediser Also see Activating numlock on bootup - ArchWiki

Hope this helps!