Nfs-server Failed to mount RPC Pipe File System

getting Failed to mount RPC Pipe File System. when trying to start nfs-server.
brand new Manjaro install.

Linux CatCave 7.1.8-1-MANJARO #1 SMP PREEMPT_DYNAMIC Sun, 09 Aug 2026 19:32:16 +0000 x86_64 GNU/Linux
rpcbind active:
● rpcbind.service - RPC Bind 
     Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; enabled; preset: disabled) 
     Active: active (running) since Wed 2026-08-26 09:19:57 EDT; 1h 0min ago 
 Invocation: d5f44fec41734a26aac7ba2892f0de32 
TriggeredBy: ● rpcbind.socket 
       Docs: man:rpcbind(8) 
   Main PID: 23881 (rpcbind) 
      Tasks: 1 (limit: 9188) 
     Memory: 768K (peak: 2.4M) 
        CPU: 45ms 
     CGroup: /system.slice/rpcbind.service 
             └─23881 /usr/bin/rpcbind -w -f

====================================================

>journalctl -xe

 Support: https://forum.manjaro.org/c/support

 The unit var-lib-nfs-rpc_pipefs.mount has entered the 'failed' state with result 'exit-code'.
Aug 26 09:59:16 CatCave systemd[1]: Failed to mount RPC Pipe File System.
 Subject: A start job for unit var-lib-nfs-rpc_pipefs.mount has failed
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support

 A start job for unit var-lib-nfs-rpc_pipefs.mount has finished with a failure.

 The job identifier is 6070 and the job result is failed.
Aug 26 09:59:16 CatCave systemd[1]: Dependency failed for rpc_pipefs.target.
 Subject: A start job for unit rpc_pipefs.target has failed
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support

 A start job for unit rpc_pipefs.target has finished with a failure.

 The job identifier is 6069 and the job result is dependency.
Aug 26 09:59:16 CatCave systemd[1]: Dependency failed for RPC security service for NFS client and server.
 Subject: A start job for unit rpc-gssd.service has failed
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support

 A start job for unit rpc-gssd.service has finished with a failure.

 The job identifier is 6068 and the job result is dependency.
Aug 26 09:59:16 CatCave systemd[1]: rpc-gssd.service: Job rpc-gssd.service/start failed with result 'dependency'.
Aug 26 09:59:16 CatCave systemd[1]: Dependency failed for NFSv4 ID-name mapping service.
 Subject: A start job for unit nfs-idmapd.service has failed
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support

 A start job for unit nfs-idmapd.service has finished with a failure.

 The job identifier is 6076 and the job result is dependency.
Aug 26 09:59:16 CatCave systemd[1]: nfs-idmapd.service: Job nfs-idmapd.service/start failed with result 'dependency'.
Aug 26 09:59:16 CatCave systemd[1]: rpc_pipefs.target: Job rpc_pipefs.target/start failed with result 'dependency'.

Mod edit: tidied up the terminal outputs and encased them between 3 backticks ``` to ensure they appear as correctly formatted code. Any code or command output (such as inxi output) should be placed within a scrollable pre-formatted text enclosure according to forum guidelines.

See here for instructions :point_down:


[Mini How-To] format code or command output

Select and copy all the text in the Terminal window (minus the prompt, if you are using zsh).

Then paste the output in between two lines containing three backticks:
```
or three tildes:
~~~

Or:

Copy & paste, then highlight the pasted text and click the </> button at the top of the reply window (easier for smaller outputs).


You could try to specifically load the rpc module

I’d say the rpc module wasn’t loaded in time. Have you tried mounting the NFS shares manually now that rpc is up?

Have you started and enabled the nfs-server.service?

Example starting the service and the resulting status query

[nix@server1 ~]$ sudo systemctl start nfs-server.service
[nix@server1 ~]$ systemctl status nfs-server
● nfs-server.service - NFS server and services
     Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; disabled; preset: disabled)
     Active: active (exited) since Thu 2026-08-27 09:16:53 CEST; 2min 48s ago
 Invocation: bb1d63c2cf974898a41e3191bf049cdc
       Docs: man:rpc.nfsd(8)
             man:exportfs(8)
    Process: 1907640 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=0/SUCCESS)
    Process: 1907643 ExecStart=/bin/sh -c /usr/sbin/nfsdctl autostart || /usr/sbin/rpc.nfsd (code=exited, status=0/SUCCESS)
   Main PID: 1907643 (code=exited, status=0/SUCCESS)
   Mem peak: 2.2M
        CPU: 16ms

Aug 27 09:16:52 server1 systemd[1]: Starting NFS server and services...
Aug 27 09:16:53 server1 systemd[1]: Finished NFS server and services.

[root tip] [How To] Share data using NFS

if you refer to the title of this topic you will see: “when trying to start nfs-server”

so if I understand you correctly, when I get an error running the command:
sudo systemctl start nfs-server.service, to solve that, I should execute the command:

and when that gets an error I assume, I should then execute the command:

and so on…

have you ever heard of the saying that insanity is doing the same thing over and over again expecting a different result?

Where does @linux-aarhus make this statement?

When will you reply to this?

you do know there is no rpc module per say. there are:

lsmod
rpcsec_gss_krb5 36864 0
rpcrdma 479232 2

if you are referring to systemctl, there is no rpc.service. So saying:

is meaningless.

If you are referring to rpcbind.service, then if you look a the very beginning of my original post, I show you that I did, in fact, start that service.

If you are referring to rpc-gssd.service or rpc-statd.service, they are also running and active.

Just out of curiosity, what makes you believe that arrogance will get you anywhere?

That said, I rest my case Your Honor.

I did read the topic title but then you move on to something different.

My apologies for not understanding the topic correctly.

I did a check on one of my servers - not usually using nfs - but it would do for the test. (all my bare metal servers run Manjaro except for a Synology NAS)

  • I could start the service
  • I could export a root and a share
  • I could connect from my workstation to the share

Thus I was not able to reproduce the issue and asked a - to me relevant question - relevant because I didn’t understand the topic title as specifically related to nfs-server.service

My apologies :person_bowing:

@Far-Jmp

Off-topic: Just a “heads up”…

…is intrinsically meaningless…

Did you mean “per se”?

I believe the thread should be closed and the OP ignored. Clearly is not worth helping.