Nextcloud-client crashes with segmentation fault under Sway

Hi, everyone,

nextcloud-client broke with the 2022-01-24 testing update:

zsh: segmentation fault (core dumped)  nextcloud

Apparently, it has something to do with libQt5Core:

[  105.768843] nextcloud[1263]: segfault at 8 ip 00007feee95a1814 sp 00007ffddb72df08 error 4 in[7feee938d000+2c9000]
[  105.768885] audit: type=1701 audit(1643050572.144:85): auid=1000 uid=1000 gid=1000 ses=1 pid=1263 comm="nextcloud" exe="/usr/bin/nextcloud" sig=11 res=1
Here's my system info for reference:
  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=d362e7cd-46c1-453d-ae76-8ec6ef81bc76 rw quiet
    udev.log_priority=3 "acpi_osi=Windows 2020" acpi_backlight=vendor
  Desktop: sway 1.6.1 info: swaybar dm: N/A Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: HP product: HP ProBook 430 G5 v: N/A serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: HP model: 8377 v: KBC Version 02.41.00 serial: <filter> UEFI: HP
    v: Q85 Ver. 01.18.00 date: 11/26/2021
  ID-1: BAT0 charge: 27.1 Wh (100.0%) condition: 27.1/48.0 Wh (56.5%)
    volts: 11.9 min: 11.4 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: Full cycles: 372
  Info: model: Intel Core i5-8250U socket: BGA1356 (U3E1) note: check bits: 64
    type: MT MCP arch: Coffee Lake family: 6 model-id: 0x8E (142)
    stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1205 high: 2565 min/max: 400/3400 base/boost: 1600/3400
    scaling: driver: intel_pstate governor: powersave volts: 0.7 V
    ext-clock: 100 MHz cores: 1: 800 2: 574 3: 800 4: 2565 5: 2033 6: 800
    7: 800 8: 1268 bogomips: 28808
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: Lite-On HP HD Camera type: USB driver: uvcvideo bus-ID: 1-6:2
    chip-ID: 04ca:706e class-ID: 0e02 serial: <filter>
  Display: server: N/A compositor: sway v: 1.6.1 driver: loaded: intel
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
    bus-ID: 01:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:3 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 372.55 GiB used: 16.41 GiB (4.4%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: SanDisk model: SL16G
    size: 14.84 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> scheme: MBR
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKKW256G8
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 005C temp: 29.9 C scheme: GPT
  SMART: yes health: PASSED on: 59d 4h cycles: 1,913
    read-units: 1,698,841 [869 GB] written-units: 1,898,221 [971 GB]
  ID-3: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD6SB1M-128G-1006
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B sata: 3.1
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 706 temp: 27 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 2y 2d 11h cycles: 4027
  ID-1: / raw-size: 238.17 GiB size: 233.43 GiB (98.01%)
    used: 16.33 GiB (7.0%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 77.8 MiB (26.0%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 39.0 C pch: 35.5 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
  Processes: 219 Uptime: 1h 33m wakeups: 1 Memory: 14.94 GiB
  used: 2.57 GiB (17.2%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 981 lib: 191 Shell: Zsh (doas) v: 5.8
  default: Bash v: 5.1.16 running-in: alacritty inxi: 3.3.12

You could try:

  • another kernel like 5.10
  • reinstall nextcloud-client

I can’t replicate this on my install on stable.

Please make sure you updated everything and that you do not have any packages on ignore.

To see if you have anything on ignore you can run this little command:

cat /etc/pacman.conf | grep Ignore

Thanks, I tried reinstalling, but it didn’t help. I’ll try another kernel a little bit later today.

I’m on testing branch, it might be different on stable. And I have no ignored packages, for sure.

Tried kernel linux510, which I had been using with no issues for almost a year, since last February, but no luck: still segfaults and complains about error 4 in

OK, I found the cause: it was a qt5ct config. Apparently, for some reason, that config stopped being supported with the last update of qt5-base. I dropped the ~/.config/qt5ct directory - problem solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.