New window needs to be clicked to get focused

i have manjaro mate installed .
it’s hard to explain .
consider this situation .
pluma is opened .
i press super key and open terminal .
now terminal is opened , but if i type , the text is written in pluma .
i essentially need to click on terminal , or use alt+tab , to be able to type in terminal .
this behavior is global .
new windows does not get focus automatically .
how can i change this??

Well Mate has its own settings. I would advise you to search for “select window when mouse move over them” or similar in the Window Preferences.

I use XFCE but this might help look for the answer in MATE

In XFCE I open “Window Manager” (in Settings)

Then choose the “Focus” tab

There is a checkbox for “New window focus”, Automatically gives focus to newly created windows.

Edit: use this tool to figure out which display manager and window manager you’re using

inxi -Sazy