New to linux, extreme cpu usage, don't know what to do

Hello, i’m brand new to linux running an i9-9900k, gtx 1660ti, 32gb ram and I seem to have little to no good performance at all on linux, I just come from windows 10 and installed majaro-xfce 3 days ago on nonfree drivers.

So for the past 3 days or so I have tried everything from running CSGO with like 10fps and absolutely horrible performance even settings all the games settings to the lowest possible settings, simple task like moving windows around spike xorg to like %20, firefox takes up 60% + just by scrolling a simple text page, I even thought maybe it’s just firebox being trash so I found vimb which took just as must cpu on a single youtube page without me even touching the pc lol. I have no idea where to continue from here but I am afraid that if I keep using linux in the fashion it might destroy my hardware by overheating everything on extremely simple task… I have also tried a different window manager like awesomewm which was even worse and also destroyed my audio settings where I can not even use my mic anymore without sounding like im in a dumptruck…

I just have no idea where to go from here and need some guidance on how I can start getting my system with good specs to run at least a little decent with linux…

Hello @theseus :wink:

Sounds like the driver is not loaded properly… Could you open a terminal and type:

grep glx /var/log/Xorg.0.log

There should be displayed this:

$ grep glx /var/log/Xorg.0.log
[     9.305] (II) LoadModule: "glx"
[     9.333] (II) Loading /usr/lib/xorg/modules/extensions/
[     9.339] (II) Module glx: vendor="X.Org Foundation"
[     9.375] (II) Loading sub module "glxserver_nvidia"
[     9.375] (II) LoadModule: "glxserver_nvidia"
[     9.375] (II) Loading /usr/lib/nvidia/xorg/
[     9.488] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"

I believe it is some sort this problem:

[jared@theseus ~]$ grep glx /var/log/Xorg.0.log
[     2.615] (II) LoadModule: "glx"
[     2.617] (II) Loading /usr/lib/xorg/modules/extensions/
[     2.625] (II) Module glx: vendor="X.Org Foundation"
[     2.653] (II) Loading sub module "glxserver_nvidia"
[     2.653] (II) LoadModule: "glxserver_nvidia"
[     2.653] (II) Loading /usr/lib/nvidia/xorg/
[     2.673] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"

Alright, I got exactly what you did, I also updated my kernal to 5.10 and my nvidia drivers are at 460.32.03
Also, xorg seems to be shooting to like 30 - 40 % just on moving a window around and now it’s just stuttering lol…

screenshot - https_// (remove underscore since i can’t post links lol…)

Well i am running exactly the same driver version, but on linux54 and i use a dkms from the AUR (so no mhwd). Runs perfectly on XFCE.

$ inxi -Gazy
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ZOTAC driver: nvidia 
  v: 460.32.03 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c82 
  Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia display ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1200 s-dpi: 93 s-size: 524x321mm (20.6x12.6") 
  s-diag: 615mm (24.2") 
  Monitor-1: HDMI-0 res: 1920x1200 hz: 60 dpi: 94 size: 518x324mm (20.4x12.8") 
  diag: 611mm (24.1") 
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
  direct render: Yes 

I have installed this (keep sure you removed the installed drivers before with mhwd):

pamac build nvidia-beta-dkms nvidia-settings-beta nvidia-utils-beta opencl-nvidia-beta lib32-nvidia-utils-beta lib32-opencl-nvidia-beta

Created these files:




blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

and have run sudo nvidia-xconfig to create a default xorg.conf file.

That’s it.

1 Like
[jared@theseus ~]$ inxi -Gazy
  Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Gigabyte driver: nvidia 
  v: 460.32.03 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:2182 
  Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia display ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 2560x1080 s-dpi: 96 s-size: 677x286mm (26.7x11.3") 
  s-diag: 735mm (28.9") 
  Monitor-1: HDMI-0 res: 2560x1080 dpi: 94 size: 690x291mm (27.2x11.5") 
  diag: 749mm (29.5") 
  OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
  direct render: Yes 

Ok, so before I start this I downgraded the kernal to the LTS 5.4.89
Do I need to remove the nvidia drivers with this ? ( mhwd -r pci video-nvidia)

Because without doing all that this shows pretty much exactly what you have, unless linux simply can’t handle an ultrawide monitor. . .

Update : I ran that pacman command it it quite literally broke everything to the point where I can’t even get manjaro to load past my bios screen lol. So, yeah…

Then do a fresh install attempt.

  1. After installation install kernel 5.4 and 4.19.
  2. Auto install Nvidia driver.
  3. Boot into kernel 5.4 and remove kernel 5.10 or 5.9 (which is installed during installation).

Only kernals I had were 5.4 and 4.19
nvidia drivers where all installed.

giving up lol, spent 3 days doing nothing but trying to figure out why moving a window took up 30 to 40%cpu and why i couldn’t break more than 16 fps on something like csgo…
performance was just terrible so im going to try and a different distro like popos.

Then show us the output of “top” on console.

I already did lol, it like 2 comments up but I can’t attach images or links so i have to __ them

Well yes… this setup i is not for noobs, sorry that i mentioned it…

Well you didn’t mention that…

Good luck then with popos :wink:

The link is not functional.

It is, and like he said, remove the underscores. (read pls)

If I watch webside like, then Webcontent and Firefox is using 30 - 40% of CPU power.
I have an Intel Core I 7 6800k (6 cores).