New Raspberry Pi Kernels & Related Packages

Did not try it. Networkmanager will have to be out of the picture I imagine. I tried to build wicd from aur and hit 2 dead ends with 2 pkgbuilds there. I ran out of time before I had to go to town yesterday and never tried anything else.

I am making the attempt now. In the AUR is networkmanager-iwd, giving that a shot.

Took a while to download and build but the install was smooth and painless. All I had to do was click the wireless widget and enter the passphrase. It does not hang the reboot process and I like the messages in journalctl. I consider it an improvement all around.

Edit: One other thing, I also had to enable the iwd service.

1 Like

Sounds promising (even if I don’t use Wifi but most people do) ! The AUR package (networkmanager-iwd) has a lot of dependencies… it would not be bad if it was installed by default.
I’ve read some papers and people are really happy with iwd (latency and speed).
There is also another package that could help to ease config : AUR (en) - networkmanager-iwd-overlay

Edit : it seems that iwd doesn’t allow connection to some less secure wifi… The IWD thread (Page 11) / Networking, Server, and Protection / Arch Linux Forums

I use an old motorola b/g/n wifi router, probably close 10 years old and I am able to connect. Maybe it has been improved? And the overlay just configures iwd, this package also has a configuration overlay. But my needs are simple, so maybe it is not good for all.

@Dulbi @0n0w1c I think I found an easier method using IWD/NetworkManager with kernel 5.12 while reading the arch NetworkManager wiki instead of installing networkmanager-iwd.



Install iwd
sudo sync # just to flush the mem just in case because of improper shutdown

Restart the pi by what ever means lol…

On reboot NetworkManager does not start wpa_supplicant.service. I have connected to my home router with no password or encryption and my LG phone set up as a wifi hotspot.

With my LG phone hotspot I had previously had my password and WEP security set up and and NetworkManager used the previous config it had stored and connected ok.

1 Like

I installed the linux-rpi 5.10.25-1 from testing branch.
Then, in took those parameter from upstream in config.txt, using kms, not fkms.

I have a black screen, i can login in tty, but then, when i run Kodi, i get :
ERROR : Unable to create GUI. Exiting

Did you try with kms ?

I use fkms and fbturbo installed.

Nice answer :slight_smile:

So, you will be the last one to use that, it’s a choice…
However, kms is needed in order to have Kodi / libCEC / No flickering / No green artefacts, as already mentioned yesterday, in my opinion.
I also have those issues with linux-rpi4-mainline, so i end up installing Arch ARM kernel to have a working media center.

This is simply not true even confirmed by you the “No flickering / No green artefacts” 15 days ago you even at the time said " But no flickering issues, and no green or pink artefacts either, so this is really great, very good job" Also said in that thread by you and I libcec-rpi can be made to work.

I do not know what has changed for you in the last 15 days at your place but looks to me you have found a solution where we both are better off.

Once again, you should give it a try with kms, only to see the difference.
Of course, the difference can be useless for many as long as you do not use zooming.

Even with your kernel version you made 15 days ago, the result is really acceptable, but at some zooming ratio (1.10 and 1.11 for instance, to be accurate), there are small artifacts. So no big deal because one can put the ratio at 1.09 or 1.12.
Also, when zooming, the image can shift a little bit at left or a right, it’s not regular.
So, these are small details, of course, and nearly acceptable because we also have those small defects currently with Raspi OS and Kodi 18.7. So OK.

But now, i can tell you, this is truly perfect with kms and the last patches, really.

I had the new kernel built with the latest and tested but they pushed 2 commits today involving HEVC so re-compiling the 5.10 kernel again.

I do not use any of my arm devices to do nothing but compiling and testing. I simply do not have much time to play. I do have kodi on my desktop with tvheadend as a backend so I can tune across the satellite arc with my cband and ku dishes and view local atsc tv stations.


Do you how to understand those 2 commits ? I mean what are they supposed to fix ?
There is not enough comments for me
I am bit lost with git/branches with lot of contributors and so on…i try to understand but…

Apparently there are issues with 4k but do not know if they are related.

Looks like they removed getting the hevc clocks from the overlay and now using firmware as a source. Guessing the other one may be related. They both will be kodi related. I just tested the very latest and really could not tell any difference on my end. I am in the process of pushing the new kernel to the testing and unstable branches when the mirrors sync.

linux-rpi4 5.10.25-2
linux-rpi4-headers 5.10.25-2

@Darksky I reverted the changes back to wpa_supplicant and then went forward with your suggestion, and it works nicely. I was not looking forward to having to rebuild NetworkManager every time it updated.

1 Like

I installed this new kernel. But still some small defects, the ones in mentioned earlier. I do not speak about flickering nor big green artefacts, but small defects we already had with Rasp OS and Kodi 18.x
I got them with jelly fish video, in 10bits (jellyfish-90-mbps-hd-hevc-10bit.mkv), not with 8bits content.

I get an artefact at 1.02 when zooming (in the past it was also at 1.10), on the entire height and on the far right of the screen, maybe something like 10-20 pixels width. Also, when zooming, the video is shifted way more to the left or to the right, not progressively, and this i can’t show you with a screenshot.
Those defects are not present with kms.

I Hve not posted the latest kodi yet with popcornmix’s latest fixes. My internet got knocked out with an electric storm.

Any thoughts on why with the UEFI kernel, I do not have gpio device files?

In particular, I have a need for the /dev/gpiomem device. It is set in the kernel config but no device is created. I do not see any errors in dmesg, so not sure why it is not being created.

Not really. CONFIG_GPIO_ACPI=y was also brought in also when adding ACPI.

I wonder if setting # CONFIG_GPIO_ACPI is not set would bring it back?

It seems it is auto-selected if you select ACPI.

After messing with this, while I like the use of grub and look forward to it, however the UEFI firmware is just not there yet. Too much does not work, or maybe it does but I don’t know how to make it work.

For me:
WiFi runs slowly, at ~1.5Mb/s
fake_hardware clock and ntp fail to set the system clock
no gpio
no sound devices
no video hardware acceleration

I will see about adding u-boot to the mix, but first I will take a look at how the latest tumbleweed boots.