New Raspberry Pi 400

Great! Glad to heard all of my time yesterday was not wasted. I now have to put my thinking hat on and figure out how to redo some packages. The main issue is the linux-firmware package. We do not maintain it but we do not want outdated firmware for the pi wifi either. It may also be needed for some monitors and maybe other things at the same time.

If you have bluetooth headphones create this file. This should fix another issue in another thread.

sudo nano /usr/share/alsa/cards/RPi-WM8804.conf

<confdir:pcm/iec958.conf>
RPi-WM8804.pcm.iec958.0 {
    @args [ CARD AES0 AES1 AES2 AES3 ]
    @args.CARD {
        type string
    }
    @args.AES0 {
        type integer
    }
    @args.AES1 {
        type integer
    }
    @args.AES2 {
        type integer
    }
    @args.AES3 {
        type integer
    }
    type hooks
    slave.pcm {
        type hw
        card $CARD
    }
}

I found the alsa config file already there.

OK. I did not know that.

I received my pi 400 DEV unit and some bluetooth headphones. For those who do not have the wifi and bluetooth working by now in a nutshell here is what to do for the pi400 for wifi and bluetooth and will keep you in step when the upgraded packages make it down to the testing and stable branches:

Switch to the unstable branch if you are not there:

sudo systemctl disable brcm43438.service
sudo pacman -S firmware-raspberrypi            #Installs new firmware for the pi400
sudo pacman -S -dd brcm-patchram-plus-pi400    #Install bluetooth service for the pi400
sudo systemctl enable attach-bluetooth-pi400.service

I did a test on my pi400 using my bluetooth headphones and it worked good.

1 Like