New package nim 2.0 using new package management rules

I use Manjaro linux distribution and updated nim-lang package through Manjaro’s package manager (pamac).
When I try to run a program, I get error: Error: cannot open '/usr/lib/nim/lib/system.nim
I checked and ‘system.nim’ is on ‘/usr/lib/nim/system.nim’ path, not as where vscodium is searching.

I asked on nim-lang forum and this is the reply i got:

This will be that package management changed from 2.0
pacman has worked around this by adding a symlink
PKGBUILD · main · Arch Linux / Packaging / Packages / nim · GitLab
Does pacman work on manjaro? Surely pamac is a wrapper
You’ll need to file a bug report with your distro, you can link them to the updated packaging guidelines Packaging Nim

The nim package is imported directly from Arch. The updated package is already in the Manjaro unstable channel.

1 Like

pacman works in manjaro and exists by default.
pamac is not a wrapper for pacman … it is an ALPM frontend like pacman.
(though it still relies on some pacman configs, and uses the pacman log, etc)

But yeah - the package is from Arch and should work exactly as it does there.
(though whether its properly ‘worked around’ could be another question)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.