New octopi-0.14.0-5 fails with "octopi: /usr/lib/ version `GLIBCXX_3.4.32' not found"

On 21. July 2023 a new octopi version 0.14.0-5 has been released.

After installaton of this package, octopi fails with following error:

octopi: /usr/lib/ version `GLIBCXX_3.4.32' not found (required by octopi)

After installation of octopi version 0.14.0-4 from local cache, the problem has been resolved.

Based on following commit, the change seems not to be important:

I am running Octopi 0.14.0 pkgrel 5 - no issues.

Did you install without syncing your system?

I can confirm the bug. The highest GLIBCXX is 3.4.31.

I guess Mark Wagie has not checked that the dependency has not yet catched up in the stable branch.

[teo@teo-lenovo-v15 ~]$ octopi
octopi: /usr/lib/ version `GLIBCXX_3.4.32' not found (required by octopi)
[teo@teo-lenovo-v15 ~]$ strings /usr/lib/ | grep GLIBCXX_3.4.32
[teo@teo-lenovo-v15 ~]$ 
[teo@teo-lenovo-v15 ~]$ strings /usr/lib/ | grep GLIBCXX_3.4.31
[teo@teo-lenovo-v15 ~]$ pacman -F /usr/lib/
usr/lib/ is owned by core/gcc-libs 13.1.1-1
1 Like

Fixed with 0.14.0-5.0.

I can confirm that fixed it for me.

Yes the update works for me too.

Sorry, noob here, but how do I get the fix? I’m still on the broken version.

Wait for the mirrors to update. (or select new ones with pacman-mirrors -f 5)

Thank you, the new build fixed it for me, too.

Offtopic: sorry i didn’t realize @Yochanan = Mark Wagie = octopi package maintainer otherwise i wouldn’t have spammed per email. Somehow i have expected “MarkW” or something like that in the forum :rofl: Thanks for the fast fix.

Well, that is a logical assumption. However, I’ve been using the same username1 for well over 20 years. :man_shrugging:

1 Yocḥanan (aka John) is the Apostle Mark’s Hebrew name–whom I was named after.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.