New Manjaro User, NVIDIA driver update failed

Hello all,

I literally just installed Manjaro last night. It’s my first time using any kind of linux, and I tried running some games today, but found that they were unplayably slow (specifically astroneer on Steam-proton lol). I figured I’d update my drivers; I chose proprietary during the setup, and entered the command to download new ones. I tried rebooting and I’m met with a black screen with no cursor. Console works. I’m running Manjaro Plasma (I think that’s KDE?) and I’m desperate!

I apologize for not being very good at computer software in general. I can’t RTFM because I dont understand the language said manual is written in.



Hello and welcome to Manjaro.

What does this mean?

What did you execute?

If you have access to a TTY then maybe we can also retrieve system information using pastes;

inxi -Farz | curl -F 'file=@-'
mhwd -li -l | curl -F 'file=@-'

I ran the following in this order:

$ sudo mhwd -a pci nonfree 0300

$ sudo reboot

Sorry for not clarifying

Also both of those commands returned

“curl: (6) Could not resolve host:”

I assume this means my PC isn’t connecting to the internet…

Ok, no worries.

It would seem so.

This could be a problem.

We could begin by just removing the proprietary nvidia driver, which will hopefully return you to some normal operation.

sudo mhwd -r pci video-nvidia

We will need network access to be able to download new packages, install new kernels, update, etc.

Thank you so much. The driver was successfully removed, should I restart?

Yes - the hope is that you will have more interactivity upon reboot.

If you can get a network connection then I would suggest

Sorting mirrors

sudo pacman-mirrors --continent


sudo pacman -Syu

Install 6.6 LTS kernel

sudo mhwd-kernel -i linux66

And then you may want to try installing the nvidia driver again

sudo mhwd -i pci video-nvidia

And before rebooting I would suggest applying KMS and DRM-KMS if they are not already present.

This would mean making sure kms is present in the HOOKS array in the /etc/mkinitcpio.conf file and nvidia_drm.fbdev=1 is present in /etc/default/grub on one of the CMDLINE lines.

I suspect you need only do the second part.

sudo micro /etc/default/grub

Apply the option nvidia_drm.fbdev=1 to GRUB_CMDLINE_LINUX, so it would appear if there are no other options like


When that is finished please run

sudo mkinitcpio -P
sudo grub-mkconfig -o /boot/grub/grub.cfg

And hopefully things work on a reboot.

Make sure to test booting into both kernel 6.9 and 6.6 LTS.

(you should be able to select your kernel from GRUB during boot. If it is hidden try tapping Esc or Shift)

Thanks! Everything works great now. Thank you for your time.

Yay. Glad to hear it. :vulcan_salute:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.