New Manjaro installation shows GRUB error - Minimal BASH like line editing is supported

I installed Manjaro XFCE in a HP 250 G5 laptop, alongside KDE Neon and Windows 10.
The other operating systems are installed in UEFI mode, and I did install Manjaro in UEFI mode. There were no installation errors.

I also marked the EFI partition (FAT32) as /boot/efi during installation.

However, the computer shows the following error when I open it.

               GNU GRUB version 2.04

  Minimal BASH like line editing is supported. For the first word, TAB lists possible command completion. Anywhere else TAB lists possible device or file completions.


Right now, I have to press F9 to open boot options, from where I can manually boot with the Manjaro’s EFI entry (it opens another grub menu, which has working versions of Manjaro, KDE Neon and Windows).

How to fix this from Manjaro, without reinstalling Manjaro?

I tried running sudo update-grub from the new Manjaro installation after booting into it using its EFI file, but that did not work.

I tried Fix Minimal BASH like line editing is supported GRUB Error In Linux - It's FOSS, but that did not help.

I noticed that I can go to Manjaro grub menu if I enter the command exit. But is there a way to open the Manjaro GRUB menu by default?

I was able to solve it.

I went to BIOS setup (F10 in my HP laptop) → UEFI Boot OrderOS Boot Manager → Put Manjaro on the top by pressing F6 repeatedly → Press F10 to save and exit.

Somehow, by default, the computer was trying to boot into a non-existent Ubuntu installation.

What does efibootmgr say?
If Ubuntu is on the list you might remove it…

$ efibootmgr
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,3002,0000,0001,0004,0007,0006,2001,2002,2004
Boot0000* ubuntu
Boot0001* Windows Boot Manager
Boot0002* Manjaro
Boot0004* neon
Boot0006* Network Adapter (IPv4 Legacy)
Boot0007* Notebook Hard Drive - TOSHIBA MQ01ABD100
Boot2001* EFI USB Device
Boot3002* Internal Hard Disk or Solid State Disk

This Ubuntu is non-existent (I installed KDE Neon on top of it in 2019). I don’t know why it shows up. I removed the ubuntu directory from /boot/efi/, but it still shows up in efibootmgr.

Because I think this is entries in the motherboard itself.

You can remove unwanted entries.
Remove Ubuntu with: sudo efibootmgr -b 0000 -B

Is that ZeroZeroZeroZero or the letter o repeated four times?

The output of efibootmgr shows Zeros, whereas your suggested command contains the English letter o.

It is the corresponding number of the entry in the list, so four zeroes for Ubuntu.

Yes, it’s zeros, like on your screen behind Ubuntu,
So this: 000000 and not ooooo, so my mistake.

There were some typo in that command. The correct command is

sudo efibootmgr -b 0000 -B

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.