New manjaro installation has hangs and stalls

I already opened a topic earlier, but I was almost certain that is was network related (so I posted it there), but I no longer think that. As suggested in the other topic, I open a new - broader - question here.

I wanted to place a link to my other post, but I am not allowed to. It’s in the Networking section.

Summary: I have used Arch (i3) for years on my desktop, laptops, and even work laptop. Not that it all worked right away, but I got it to work stable and swift. But the instable nature of the software was getting in the way of my workflow, certainly for the work-laptop where I needed Virtualbox to run Windows for some small tasks (and it no longer worked on kernel 5.8). I also had a simpler configuration which was power-hungry (no prime and I think I also did some bad configuration in power management) but didn’t want to invest the time into getting deep in it. So I decided to go for Manjaro (i3), it being Arch with a more stable nature and good power management configuration. I use i3 because I love it. I grew up in the 80’s without a mouse and have always tried to only use the mouse for gaming.

But I am having issues with things I didn’t have issues with when I was using Arch:

  • After booting, the wifi network starts up fine, but the NetworkManager-applet hangs for about 30 seconds before appearing on the tray. When I click on it, it does nothing until the hang is finished. When it is shown, it still has this issue, because clicking on it doesn’t show the popup window for again some 30 seconds. The network works though.
  • The same happens if I try to use pulseaudio: if it is set up to start with the bootup process, it won’t work. The sound will still be just ALSA. PavuControl will say it is looking for pulseaudio and waits forever. Pulseaudio is running however, and if I kill it and restart it manually, it works fine.
  • The pa-applet for volume control on pulseaudio has the same issues as the NetworkManager-applet. It will wait up to 30 seconds to show up on the tray and when clicked, it will take about 30 seconds to react. The keyboard volume controls (once I restarted pulseaudio of course) will work, but also with the necessary delays: when I am listening to music, and change the volume with the Fn-buttons, it will take up to a minute to adjust, but it does adjust.
  • Sometimes it makes the i3 status bar hang too, but that’s seldom.
  • After playing a Steam game, Steam synchronizes the saves to the Steam cloud. Sometimes it will start synchronizing and then the system will just completely hang. The synchronization doesn’t happen, everything hangs. Waiting it out doesn’t work. I have to hard reset the computer and I’ve already had a corrupted save because of it.
  • Sometimes the above doesn’t hang immediately but it stutters, first 10 seconds that I can’t move the mouse, then a brief moment of activity, then 20 seconds, then a brief moment of activity, then hangs forever like the above.
  • When using nvidia 450 driver (this may be a completely unrelated thing), xrandr may take up to 3 seconds to start up. I use xrandr with my Fn-brightness keys because I have an OLED screen. Once it has started, it will work immediately for the next presses until some time has passed.
  • Something I started noticing too is that notifications in Firefox (I don’t know if it comes from Firefox) take long too on the laptop - when I have this forum open on my desktop and my laptop, I receive notifications immediately on the desktop, but it takes again around 30 seconds to show up on the laptop, same with whatsapp web notifications.

To make it clear: I have installed manjaro-i3 edition on both my laptop and my desktop. Everything works fantastic on the desktop.

I didn’t have all this with my Arch installation, but it wasn’t that well configured either (for example, I only used the dgpu, no prime), but the system was always very responsive and stable, never had these hangs as far as I remember.

Things I have tried (as you can read in the mentioned post):

  • Kernel 5.4 LTS, kernel 5.7 (default) and kernel 5.8 - all of them have the same issues
  • Connman instead of NetworkManager - same kinds of issues
  • Nvidia 440 instead of 450 -> it solves the xrandr issue but then I can’t access my HDMI port. The latter is more important to me, so I went back to 450. I don’t understand this because it seems that my Intel GPU should also have access to the HDMI port if I look at my hardware setup.
  • Change swappiness - but as I don’t use a swap disk because I have 32GB of memory (and never needed it before on any pc in years since I have 32GB of memory) I don’t think it matters.
  • Tried lots of other things I am probably forgetting now.

Please help… I really want to use Manjaro as I grew so fond of Arch. For me it is so much better/familiar than Debian or Redhat based systems on which I always have trouble feeling at home.

Try kernel 4.19 and 4.14.

My wifi won’t work on both of them, but NetworkManager isn’t stalling on these kernels.
So it’s kernel or wifi related.
But I’ve used wifi on Arch succesfully. Is there a different driver I can use for my wifi adapter? It’s an Intel Corporation Wi-Fi 6 AX200.

You could try to build yourself the iwlwifi module from the backport tree:

https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git/

Have you seen this thread in the old forum?

Are there instructions on how to do that? I know how to clone the git repo and usually there’s a README or something with instructions, but not in this one.
Any links to instructions on doing this?
Edit: I think I did it, see next post

No, I did do searches before posting here however :slight_smile:

$ sudo make
$ sudo make install
Your driver should be installed. Reboot.

I rebooted… same issues :frowning:. Not sure how to check if I’m using that backport driver though. How do I check that?

I stopped trying and went back to Arch for my laptop. I accepted that it would take a long time to study all the things I wanted Manjaro to take care of for me, but now my laptop works perfectly (great battery life and hybrid graphics now) and I have none of the issues I mentioned in this post. I learnt a lot from you guys, however. Thanks!

My desktop, however is working perfectly fine with Manjaro and I think I will keep it that way.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.