New KDE plasma 5.24 fingerprint login feature not working (fingerprint reader is working)


I recently updated to KDE Plasma 5.24.4 , which should now support fingerprint login automatically (KDE Plasma 5.24 will receive fingerprint support | Ubunlog) which is much smoother than the former unlocking via fingerprint approaches. I have a Lenovo Thinkpad X1 Gen7 running on Manjaro 5.17.1 and the fingerprint reader works in principle fine:

Bus 001 Device 003: ID 06cb:00bd Synaptics, Inc. Prometheus MIS Touch Fingerprint Reader

However somehow KDE does not allow me to use it to unlock. You can see here, that I can add fingerprints:

which I did. Also in the terminal the fprintd commands work fine:

thinkpad>fprintd-list ahampel
found 1 devices
Device at /net/reactivated/Fprint/Device/0
Using device /net/reactivated/Fprint/Device/0
Fingerprints for user ahampel on Synaptics Sensors (press):
 - #0: left-index-finger
 - #1: right-index-finger
 - #2: right-middle-finger
Using device /net/reactivated/Fprint/Device/0
Listing enrolled fingers:
 - #0: left-index-finger
 - #1: right-index-finger
 - #2: right-middle-finger
Verify started!
Verifying: left-index-finger
Verify result: verify-match (done)

But there is this strange sentence that you can see in the screenshot saying: “Logging into the system with your fingerprint is not yet supported” :

Any idea why? There is also no sign in the lock screen that looks similar to what I found in youtube videos.

Is there some configuration that I can check? I used my fingerprint reader once on this installation to unlock the screen etc but removed the pam entries again. Did KDE not update something properly?

I checked similar topics but most people seem to have trouble to get their fingerprint reader working, which is fine for me. Let me know if I overlooked another topic.

Any help welcome. Thanks.

Because you din’t modified your PAM rules. To enable fingerprint login with SDDM you need to add on the top in /etc/pam.d/sddm:

auth 			sufficient

Do same thing for other apps if you wish use fingerprint for them (eg. sudo), but be careful to not lock your system :wink:

Hi Tomek,
thank you. That worked for me somewhat. But this is now still very similar to the way it worked already half a year ago. When I am in the lock screen I have to press enter twice, then I get this little message that I can place my finger on the finger print reader. But for example in this KDE promo video: there is no such message and no pressing enter. Just put the finger on the reader and it automatically unlocks. Hence, I wonder if this is still a different feature? Or is the only new thing in KDE plasma 5.24 that I can manage my fingerprints in a gui under settings?

If I see correctly, this is lock screen, not login screen.

Ah sry, I was already one step further. I added this to my etc/pam.d/kde at the top

auth            sufficient try_first_pass likeauth nullok
auth            sufficient

which let’s me use the fingerprint to unlock. But as I said I have to press enter twice to activate. I guess at this stage I am almost satisfied with the solution. I am just confused what they actually added then in plasma 5.24 . Because, this is how the fingerprint unlock in kde always worked. Nothing new, and in the video it looks different.