New kde minimal installation iso broken with XFS

I tryed to create new system from latest kde minimal image.
I used everything default except choising XFS filesystem and swap without hibernation.

In the end of install I got error - unable to install efi boot loader.

The same error I got when tested in virtualbox with efi enabled for vm, but think that I messed something with vm config.

Now I got dead system, writing from microwave.

I tryed fixing boot by chrooting to installed system but got error something like grub do not see efi partition (mounted it to tmp/installroot/boot and also tryed boot/efi)

Please someone check if kde mininal image actually work or not on efi system/vm with XFS filesystem.

How did you write th ISO?
How are you booting it?
Are you in EFI mode?
Are there other systems already existing? Maybe ones that would have encrypted the ESP?
Is BIOS set to AHCI ?

xfs is always an on off love principle. It mostly depends on the version of grub, the xfsprogs and other things. For this release we didn’t test xfs at all. So it might be broken.

I did it as usual.
I have nvme ssd.

I believe @cscs was asking for more information than that. Also, please don’t ignore the comment from @philm.

Aside:- This may have no bearing on the XFS topic, however, consider using the full ISO instead, despite the relative size differential. Doing so should ensure that you won’t be missing a package or feature you might have otherwise expected to be present. That is all. Cheers.

I updated grub to the latest code, which can be tested with this image: Release 202312180240 · manjaro-plasma/download · GitHub. So @Nyakov13 let me know if that fixes your issue with xfs.

1 Like


Tested the December 15. ISO with xfs - bootloader installation fails with unknown filesystem

Tested the December 18. ISO preview with xfs - bootloader installation works

There is still somthing flaky with the xfs filesystem - several identical messages are displayed when booting the system

error: attempt to read or write outside partition.

I have no experience with xfs - so I have no idea what this is about - my personal suggestion is to use another filesystem … e.g. btrfs or ext4 … this just my personal opinion - don’t take for anything but that.

1 Like

Yes. Its working. Thank you!
Tested with build from 2023-12-19

Was busy getting working system, writing late at night from smart iron. Still not finish… I thought that “not working” in VM and on real hardware will be enough considering issue severity.

This was very interesting read, thank you!

Grub 2.12 just got released. So the next ISO will ship with that.