New kde install on HiDPI has text and icons and tray tiny

[clone of forum: high-res-screen-with-new-install-gets-tiny-fonts-and-icons/35874/10 , now targeted at kde, since kde is where I’ve ended up]
I have an alienware m17 r3 laptop with 3840x2160 screen.
Linux version 5.8.18-1-MANJARO (builder@b81df68610d1)
lspci says: Intel Corporation UHD Graphics (rev 05), and NVIDIA Corporation TU106M [GeForce RTX 2060 Mobile] (rev a1).
(total manjaro newbie, first linux install in years)
After fresh install, I get all text, menus, and icons are tiny.
I tried PLASMA_USE_QT_SCALING=1, which totally breaks the window manager.

Using cscs/hidpify with DPI=240, I get some success:

app default font sizes are OK.
background menu is OK.
But, the icons in the ‘tray’ are extremely small. Is there some overall better approach? Or is there a specific tweak to fix the icon tray?

– George

Hey its me. :slight_smile:

That you might have to set ala:

Alas, System Settings->Icons->Configure Icon Sizes ==> 128 (or 64) seems to do nothing.
Any other ideas?

– George (reluctantly beginning to regret trying manjaro…)

This has nothing to do with manjaro.
This is KDE + your HiDPI. It would be the same on any other KDE.
Just because you dont know how to apply a setting is no reason to start throwing shade at the distro…

Sorry … do you mean the system tray?
It has its own settings for ‘small’ or ‘scale with panel’.

Here is an example of putting the panel into ‘edit mode’ and selecting system tray configuation


Make sure the ‘scale’ method is checked and the icons should grow with your panel:

OK, I get the Configure Desktop and Wallpaper, but the options there are:
mouse actions

I don’t see ‘General’, and none of the above have an entry like Panel icon size. Is that setting configurable in some config file that I can edit?

But thats not what you need … thats just a button from the desktop being in edit mode that happens to be in the background of my screenshot.

  • Right click on the panel
  • Select “Edit Panel”
  • Hover over System Tray
  • Click “Configure”

(normally you could just right-click on things, but as system tray is populated with interactive items, its sort of difficult to do without putting things into the ‘edit mode’)

Got it. I clicked Scale with panel height. Then did edit panel and changed panel height and voila, my screen looks much happier!
Thank you so much for you help and for your patience!

– George

1 Like

HiDPI is sorta finnicky sometimes … I honestly cant think of a Desktop or OS I am happy with it on … at least KDE affords me the ability to tweak it to just about right. (and hence the script)
I wish you luck on your journey. :penguin:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.