New install on Pi 4B, network doesn't start

I have been happily running Manjaro on an old x86_64 for some time as a platform for development. Now that the code is working, I wanted to port it to Raspberry Pi so I tried it with Raspberry Pi OS and it didn’t work quite the same way. The device drivers involved are from a different fork on Raspberry Pi OS to those on Manjaro so I thought I’d try Manjaro on the Pi to see if it would change anything.

I created a 32GB uSDHC with Raspberry Pi imager, Pi4B distribution, with both Plasma and Minimal. The network doesn’t start on either of them. On Raspberry Pi OS with the same hardware it does - and I’ve switched back and forth a couple of times, as well as trying a different port/cable, and a different Pi. Always the Manjaro edition doesn’t start and ip a show both wlan0 and end0 “NO-CARRIER”…

I’ve updated the eeprom just to make sure without effect. It doesn’t make sense to me and from research it doesn’t seem like a lot of people have this problem. Am I missing something?


1 Like

Me either You should have had at least the ethernet working. Some have issues with wifi and their router. I really do not suggest starting with the images on the Downloads page. They are just too old. Use one of these DEV images.

1 Like

Or even better, build it yourself.

sudo pacman -Syu manjaro-arm-installer
sudo systemctl restart systemd-binfmt
sudo bash manjaro-arm-installer

If he does that he really needs to use the unstable branch. There has been a ton of kernel bugfixes that has not made it to the stable branch.

git clone
cd manjaro-arm-installer
Install depends in the README
sudo bash ./manjaro-arm-installer arm-unstable
1 Like

I tried the 20231204 release and managed to get WiFi up. I probably could have done it on the release from the download page as well. The wired ethernet remains obstinately down. The NO CARRIER message to me means it believes there’s no link there, but there is and it works, at least on Raspberry Pi OS. It’s a gigabit interface by the way. Maybe I’ll try a slower one tomorrow.

With WiFi I can do the test I wanted to run in the first place, The code I wrote is for an RTL-SDR USB dongle, and it behaves a bit differently on the Pi under Raspberry Pi OS. The device drivers come from a different fork to those from Manjaro, so I wanted to check Manjaro on the Pi to see if it made a difference.

Thanks for the suggestions. I’ll keep plugging away.


There are some kernel modules that interfers with the RTL-SDR. Have you blacklist them? Other than having to blacklist modules I generally have not had any issues using my RTL-SDR with various programs.


blacklist dvb_usb_rtl28xxu
blacklist rtl2832
blacklist rtl2830

Strange - I have created a couple of cards yesterday (2023-12-18T23:00:00Z) using manjaro-arm-installer and stable branch.

Booting a Pi4 was without any hickups.

Ethernet OOB - no use for wifi - so there’s that.

I am a little perplexed also. I do not remember anyone having an issue with the onboard ethernet and the way he has worded it I am not sure he is using it either. The base kernel modules are the same as PiOS. All I have done is add a few more modules that people here have requested.

Thanks for the comments. The RTL-SDR drivers were not interfering as I was using a clean install, and hadn’t installed the rtl-sdr package yet, or anything else for that matter. As the message is “NO CARRIER” in ip a I’m suspecting there’s something weird in the 1Gb connection that Manjaro doesn’t like, but as I said it fine with Raspberry Pi OS.

As for my RTL-SDR experiment, I think I was chasing a red herring and the problem is actually the antennas rather than the computer end. I did a side by side test with a T-connector from a single antenna and other than the local oscillator frequency is a bit different between the two dongles I have the recorded signals are very similar.

Thanks again for your comments and suggestions.


I’ve tested the Pi 4 and 5, but have yet to test the Pi 3+.
Both had ethernet connections and received IP addresses from my router.
Because my Australian internet connection requires two power plugs to function, it was only a quick test.

I never got wired to work. Wi-Fi worked after some fiddling. I’ve shelved it as the problem was not specific to the Pi, but the time of day I was using it.

Thanks for the suggestions,